Home > Cisco > Router > Cisco Router 850 Series Software Configuration Guide

Cisco Router 850 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 850 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    							 
    13-9
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the Console or Auxiliary Port
    !dsl operating-mode auto
    !
    ! Dial backup interface, associated with physical BRI0 interface. ! Dialer pool 1 associates it with BRI0’s dialer pool member 1. 
    ! Note “dialer watch-group 1” associates a watch list with corresponding 
    ! “dialer watch-list” command.interface Dialer0
     ip address negotiated
     encapsulation ppp dialer pool 1
     dialer idle-timeout 30
     dialer string 384040 dialer watch-group 1
     dialer-group 1
    !! Primary interface associated with physical ATM0 interface. 
    ! Dialer pool 2 associates it with ATM0’s dial-pool-number2.
    interface Dialer2 ip address negotiated
     ip mtu 1492
     encapsulation ppp dialer pool 2
     dialer-group 2
     no cdp enable
    !ip classless
    !
    ! Primary and backup interface are given route metric.ip route 0.0.0.0 0.0.0.0 22.0.0.2
    ip route 0.0.0.0 0.0.0.0 192.168.2.2 80
    ip http server!
    ! Watch for interesting traffic.
    dialer watch-list 1 ip 22.0.0.2 255.255.255.255
    ! Specifies interesting traffic to trigger backup ISDN traffic.
    dialer-list 1 protocol ip permit!
    Configuring Dial Backup and Remote Management Through the 
    Console or Auxiliary Port
    When customer premises equipment, such as a Cisco 850 or Cisco 870 series router is connected to an 
    ISP, an IP address is dynamically assigned to the router, or the IP address may be assigned by the router 
    peer through the centrally managed function. The dial backup feature can be added to provide a failover 
    route in case the primary line fails. Cisco 850 and Cisco 870 routers can use the auxiliary port for dial 
    backup and remote management.
    NoteThe cable modem environment is currently not supported. 
    						
    							
     
    13-10
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the Console or Auxiliary Port
    Figure 13-1  shows the network configuration used for remote management access and for providing 
    backup to the primary WAN line.
    Figure 13-1 Dial Backup and Remote Manage ment Through the Auxiliary Port
    82269
    A1
    3
    2
    2
    C
    B
    BC
    2
    AT M
    PSTN
    1Cisco 850 or Cisco 870 
    series routerAMain WAN link; primary connection to Internet service provider
    2ModemBDial backup; serves as a failover link for Cisco 870 routers when 
    primary line goes down
    3PCCRemote management; serves as dial-in access to allow changes or 
    updates to Cisco IOS configurations
    Configuration Tasks
    Perform these steps to configure dial backup and re mote management for these routers, beginning in 
    global configuration mode:
    CommandPurpose
    Step 1ip name-server  server-address
    Example:
    Router(config)#  ip name-server 
    192.168.28.12
    Router(config)#
    Enters your ISP DNS IP address.
    Ti pYou may add multiple server addresses if 
    available.
    Step 2ip dhcp pool  name
    Example:
    Router(config)#  ip dhcp pool 1
    Router(config-dhcp)#
    Creates a DHCP address pool on the router and 
    enters DHCP pool configuration mode. The  name 
    argument can be a string or an integer.
     Configure the DHCP address pool. For 
    sample commands you can use in DHCP pool 
    configuration mode, see the 
    “Configuration 
    Example” section on page 13-13. 
    						
    							 
    13-11
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the Console or Auxiliary Port
    Step 3exit
    Example:
    Router(config-dhcp)# exitRouter(config)#
    Enters global configuration mode.
    Step 4chat-script script-name expect-send
    Example:
    Router(config)# chat-script Dialout ABORT 
    ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102 
    T” TIMEOUT 45 CONNECT \c
    Router(config)#
    Configures a chat script used in dial-on-demand 
    routing (DDR) to give commands to dial a modem 
    and to log in to remote systems. The defined script 
    is used to place a call over a modem.
    Step 5interface type number
    Example:
    Router(config)# interface Async 1Router(config-if)#
    Creates and enters configuration mode for the 
    asynchronous interface.
     Configure the asynchronous interface. For 
    sample commands you can use in async 
    interface configuration mode, see the 
    “Configuration Example” section on 
    page 13-13.
    Step 6exit
    Example:
    Router(config-if)# exit
    Router(config)#
    Enters global configuration mode.
    Step 7interface type number
    Example:
    Router(config)# interface Dialer 3Router(config-if)#
    Enters interface configuration mode.
    Step 8dialer watch-group group-number
    Example:
    Router(config-if)# dialer watch-group 1
    Router(config-if)#
    Specifies the group number for watch list.
    Step 9exit
    Example:
    Router(config-if)# exit
    Router(config)#
    Enters global configuration mode.
    Command Purpose 
    						
    							 
    13-12
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the Console or Auxiliary Port
    Step 10ip nat inside source {list access-list-number} 
    {interface type number | pool name} [overload]
    Example:
    Router(config)# ip nat inside source list 
    101 interface Dialer 3 overload
    Enables dynamic translation of addresses on the 
    inside interface.
    Step 11ip route prefix mask {ip-address | interface-type 
    interface-number [ip-address]}
    Example:
    Router(config)# ip route 0.0.0.0 0.0.0.0 
    22.0.0.2
    Router(config)#
    Sets the IP route to point to the dialer interface as 
    a default gateway.
    Step 12access-list access-list-number {deny | permit} 
    source [source-wildcard]
    Example:
    Router(config)# access-list 1 permit 
    192.168.0.0 0.0.255.255 any
    Defines an extended access list that indicates 
    which addresses need translation.
    Step 13dialerwatch-list group-number {ip ip-address 
    address-mask | delay route-check initial 
    seconds}
    Example:
    Router(config)# dialer watch-list 1 ip 
    22.0.0.2 255.255.255.255
    Router(config)#
    Evaluates the status of the primary link, based on 
    the existence of routes to the peer. 22.0.0.2 is the 
    peer IP address of the ISP.
    Step 14line [aux | console | tty | vty] line-number 
    [ending-line-number]
    Example:
    Router(config)# line console 0Router(config-line)#
    Enters configuration mode for the line interface.
    Step 15modem enable
    Example:
    Router(config-line)# modem enable
    Router(config-line)#
    Switches the port from console to auxiliary port 
    function.
    Step 16exit
    Example:
    Router(config-line)# exit
    Router(config)#
    Enters global configuration mode.
    Command Purpose 
    						
    							 
    13-13
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the Console or Auxiliary Port
    Configuration Example
    The following configuration example specifies an IP address for the ATM interface through PPP/IPCP 
    address negotiation and dial backup over the console port.
    !
    ip name-server 192.168.28.12ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool 1 import all
     network 192.168.1.0 255.255.255.0
     default-router 192.168.1.1!
    ! Need to use your own correct ISP phone number.
    modemcap entry MY-USER_MODEM:MSC=&F1S0=1chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102\T”
    TIMEOUT 45 CONNECT \c
    !!
    !
    !interface vlan 1
     ip address 192.168.1.1 255.255.255.0
     ip nat inside ip tcp adjust-mss 1452
     hold-queue 100 out
    !! Dial backup and remote management physical interface.
    interface Async1
     no ip address encapsulation ppp
     dialer in-band
     dialer pool-member 3 async default routing
     async dynamic routing
     async mode dedicated ppp authentication pap callin
    !
    Step 17line [aux | console | tty | vty] line-number 
    [ending-line-number]
    Example:
    Router(config)# line aux 0Router(config)#
    Enters configuration mode for the auxiliary 
    interface.
    Step 18flowcontrol {none | software [lock] [in | out] | 
    hardware [in | out]} 
    Example:
    Router(config)# flowcontrol hardware
    Router(config)#
    Enables hardware signal flow control.
    Command Purpose 
    						
    							 
    13-14
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the Console or Auxiliary Port
    interface ATM0 mtu 1492
     no ip address
     no atm ilmi-keepalive pvc 0/35
     pppoe-client dial-pool-number 1
    !dsl operating-mode auto
    !
    ! Primary WAN link.interface Dialer1
     ip address negotiated
     ip nat outside encapsulation ppp
     dialer pool 1
     ppp authentication pap callin ppp pap sent-username account password 7 pass
     ppp ipcp dns request
     ppp ipcp wins request ppp ipcp mask request
    !
    ! Dialer backup logical interface.interface Dialer3
     ip address negotiated
     ip nat outside
     encapsulation ppp no ip route-cache
     no ip mroute-cache
     dialer pool 3 dialer idle-timeout 60
     dialer string 5555102 modem-script Dialout
     dialer watch-group 1!
    ! Remote management PC IP address.
    peer default ip address 192.168.2.2no cdp enable
    !
    ! Need to use your own ISP account and password.ppp pap sent-username account password 7 pass
    ppp ipcp dns request
    ppp ipcp wins requestppp ipcp mask request
    !
    ! IP NAT over Dialer interface using route-map.ip nat inside source route-map main interface Dialer1 overload
    ip nat inside source route-map secondary interface Dialer3 overload
    ip classless!
    ! When primary link is up again, distance 50 will override 80 if dial backup 
    ! has not timed out. Use multiple routes because peer IP addresses are alternated ! among them when the CPE is connected.
    ip route 0.0.0.0 0.0.0.0 64.161.31.254 50
    ip route 0.0.0.0 0.0.0.0 66.125.91.254 50ip route 0.0.0.0 0.0.0.0 64.174.91.254 50
    ip route 0.0.0.0 0.0.0.0 63.203.35.136 80
    ip route 0.0.0.0 0.0.0.0 63.203.35.137 80ip route 0.0.0.0 0.0.0.0 63.203.35.138 80
    ip route 0.0.0.0 0.0.0.0 63.203.35.139 80
    ip route 0.0.0.0 0.0.0.0 63.203.35.140 80ip route 0.0.0.0 0.0.0.0 63.203.35.141 80
    ip route 0.0.0.0 0.0.0.0 Dialer1 150
    no ip http serverip pim bidir-enable
    ! 
    						
    							 
    13-15
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the Console or Auxiliary Port
    ! PC IP address behind CPE.access-list 101 permit ip 192.168.0.0 0.0.255.255 any
    access-list 103 permit ip 192.168.0.0 0.0.255.255 any
    !! Watch multiple IP addresses because peers are alternated 
    ! among them when the CPE is connected.
    dialer watch-list 1 ip 64.161.31.254 255.255.255.255dialer watch-list 1 ip 64.174.91.254 255.255.255.255
    dialer watch-list 1 ip 64.125.91.254 255.255.255.255
    !! Dial backup will kick in if primary link is not available 
    ! 5 minutes after CPE starts up.
    dialer watch-list 1 delay route-check initial 300dialer-list 1 protocol ip permit
    !
    ! Direct traffic to an interface only if the dialer is assigned an IP address.route-map main permit 10
     match ip address 101
     match interface Dialer1!
    route-map secondary permit 10
     match ip address 103 match interface Dialer3
    !
    ! Change console to aux function.
    line con 0 exec-timedout 0 0
     modem enable
     stopbits 1line aux 0
     exec-timeout 0 0
     ! To enable and communicate with the external modem properly. script dialer Dialout
     modem InOut
     modem autoconfigure discovery transport input all 
     stopbits 1
     speed 115200 flowcontrol hardware
    line vty 0 4
     exec-timeout 0 0 password cisco
     login
    !scheduler max-task-time 5000
    end 
    						
    							
     
    13-16
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the ISDN S/T Port
    Configuring Dial Backup and Remote Management Through the 
    ISDN S/T Port
    Cisco 876 and Cisco 878 routers can use the ISDN S/T  port for remote management. With an advanced 
    enterprise (c870-adventerprisek9-mz) image, a Cisco  876 router can also use the ISDN S/T port for 
    dial
     backup.
    Figure 13-2  and  Figure 13-3 show two typical network configurations used to provide remote 
    management access and backup for the primary WAN line. In Figure 13-2, the dial backup link goes 
    through a customer premises equi pment (CPE) splitter, a digital subscriber line access multiplexer 
    (DSLAM), and a central office (CO) splitter  before connecting to the ISDN switch. In 
    Figure 13-3, the 
    dial backup link goes dire ctly from the Cisco router to the ISDN switch.
    Figure 13-2 Dial Backup Through CPE Spli tter, DSLAM, and CO Splitter
    82892
    AT M
    network
    Internet
    B
    23
    4
    87
    6
    5
    C
    A
    1
    1Cisco 876 or Cisco 878 routerAPrimary DSL interface
    2DSLAMBDial backup and remote management through the 
    ISDN interface (ISDN S/T port); serves as a 
    failover link when the primary line goes down
    3ATM aggregator
    4ISDN switch
    5ISDNCAdministrator remote ma nagement through the 
    ISDN interface when the primary DSL link is 
    down; serves as dial-in access to allow changes or 
    updates to Cisco IOS configuration
    6ISDN peer router
    7We b  s e r v e r
    8Administrator—— 
    						
    							
     
    13-17
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management   Configuring Dial Backup and Remote Management Through the ISDN S/T Port
    Figure 13-3 Dial Backup Directly from Router to ISDN Switch
    88208
    AT M
    network
    Internet
    B
    5
    4
    3
    76
    C
    A
    12
    1PCAPrimary DSL interface
    2Cisco 876 routerBDial backup and remote management through the ISDN 
    interface (ISDN S/T port); serves as a failover link when the 
    primary line goes
     down3DSLAM
    4Aggregator
    5ISDN switchCAdministrator remote manageme nt through the ISDN interface 
    when the primary DSL link is down; serves as dial-in access to 
    allow changes or updates to Cisco IOS configuration
    6We b  s e r v e r
    7Administrator
    Configuration Tasks
    Perform the following tasks to configure dial backup and remote management through the ISDN S/T port 
    of your router:
     Configure ISDN Settings
     Configure the Aggregator and ISDN Peer Router
    Configure ISDN Settings
    NoteTraffic of interest must be present to activate the  backup ISDN line by means of the backup interface and 
    floating static routes methods. Traffic of interest is  not needed for the dialer watch to activate the backup 
    ISDN line. 
    						
    							 
    13-18
    Cisco 850 Series and Cisco 870 Series Access Routers Software Configuration Guide
    OL-5332-01 
    Chapter 13      Configuring Dial Backup and Remote Management
      Configuring Dial Backup and Remote Management Through the ISDN S/T Port
    Perform these steps to configure your router ISDN interface for use as a backup interface, beginning in 
    global configuration mode:
    CommandPurpose
    Step 1isdn switch-type switch-type
    Example:
    Router(config)# isdn switch-type basic-net3
    Router(config)#
    Specifies the ISDN switch type.
    The example specifies a switch type used in 
    Australia, Europe, and the United Kingdom. For 
    details on other switch types supported, see the 
    Cisco IOS Dial Technologies Command 
    Reference.
    Step 2interface type number
    Example:
    Router(config)# interface bri 0
    Router(config-if)#
    Enters configuration mode for the ISDN Basic 
    Rate Interface (BRI). 
    Step 3encapsulation encapsulation-type
    Example:
    Router(config-if)# encapsulation ppp
    Router(config-if)#
    Sets the BRI0 interface encapsulation type.
    Step 4dialer pool-member number
    Example:
    Router(config-if)# dialer pool-member 1
    Router(config-if)#
    Specifies the dialer pool membership.
    Step 5isdn switch-type switch-type
    Example:
    Router(config-if)# isdn switch-type 
    basic-net3
    Router(config-if)#
    Specifies the ISDN switch type.
    Step 6exit
    Example:
    Router(config-if)# exitRouter(config)#
    Enters global configuration mode.
    Step 7interface dialer dialer-rotary-group-number
    Example:
    Router(config)# interface dialer 0
    Router(config-if)#
    Creates a dialer interface (numbered 0–255) and 
    enters interface configuration mode. 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 850 Series Software Configuration Guide