Home > Cisco > Router > Cisco Router 860, 880 Series User Manual

Cisco Router 860, 880 Series User Manual

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 860, 880 Series User Manual online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    							 
    3-9
    Cisco 860 and Cisco 880 Series Integrated Services Routers Software Configuration Guide
    OL-xxxxx-xx
    Chapter 3      Basic Router Configuration
      Configuring Basic Parameters
    For complete information on the G.SHDSL commands, see the Cisco IOS Release 12.4(15)XZ 
    documentation set. 
    Example
    The following configuration example shows a 4-wire standard G.SHDSL configuration.
    !controller DSL 0
     mode atm
     line-term cpe line-mode 4-wire standard
     dsl-mode shdsl symmetric annex B
     line-rate 4608!
    interface BRI0
     no ip address encapsulation hdlc
     shutdown
     isdn termination multidrop!
    !
    interface ATM0 ip address 10.10.10.1 255.255.255.0
     no atm ilmi-keepalive
     pvc 0/35   protocol ip 10.10.10.2 broadcast
      encapsulation aal5snap
     !!
    interface FastEthernet0
    !interface FastEthernet1
    !
    interface FastEthernet2!
    interface FastEthernet3
     shutdown!
    interface Vlan1
     ip address 2.15.15.26 255.255.255.0
    Step 11Router(config-ctrl)# protocol ip 10.10.10.2 
    broadcast(Optional) Enables IP connectivity and creates a 
    point-to-point IP address for the VC. 
    Step 12Router(config-ctrl)# encapsulation aal5snap(Optional) Configures the ATM adaptation layer 
    (AAL) and encapsulation type. 
     Use the aal2 keyword for AAL2 
     Use the aal5ciscoppp keyword for Cisco PPP 
    over AAL5 
     Use the aal5mux keyword for AAL5+MUX 
     Use the aal5nlpid keyword for AAL5+NLPID 
     Use the aal5snap keyword for 
    AAL5+LLC/SNAP (the default)
    Command Purpose 
    						
    							 
    3-10
    Cisco 860 and Cisco 880 Series Integrated Services Routers Software Configuration Guide
    OL-xxxxx-xx
    Chapter 3      Basic Router Configuration
      Configuring Basic Parameters
    !ip forward-protocol nd
    ip route 223.255.254.254 255.255.255.255 Vlan1
    no ip http serverno ip http secure-server
    !
    Verifying Configuration
    To verify that you have properly configured the router, enter the show run command and look for 
    controller DSL and interface ATM0 paramters.
    Router#sh run
    Building configuration...
     Current configuration : 1298 bytes
    !
    ....... 
    !
    controller DSL 0 mode atm
     line-term cpe
     line-mode 4-wire standard
     dsl-mode shdsl symmetric annex B line-rate 4608
    !         
    !interface ATM0
     ip address 10.10.10.1 255.255.255.0
     no atm ilmi-keepalive pvc 0/31 
      protocol ip 10.10.10.5 broadcast
      encapsulation aal5snap !
    Configuring a Wireless Interface
    The wireless interface enables connection to the router through a wireless LAN connection. For more 
    information about configuring a wireless connection, see 
    Chapter 13, “Configuring VLANs,” and the 
    Cisco Access Router Wireless Configuration Guide.
    Configuring a Loopback Interface
    The loopback interface acts as a placeholder for the static IP address and provides default routing 
    information.
    For complete information on the loopback commands, see the Cisco IOS Release 12.4(15)XZ 
    documentation
     set.  
    						
    							 
    3-11
    Cisco 860 and Cisco 880 Series Integrated Services Routers Software Configuration Guide
    OL-xxxxx-xx
    Chapter 3      Basic Router Configuration
      Configuring Basic Parameters
    To configure a loopback interface perform these steps, beginning in global configuration mode:
    Example
    The loopback interface in this sample configuration is used to support Network Address Translation 
    (NAT) on the virtual-template interface. This configuration example shows the loopback interface 
    configured on the Fast Ethernet interface with an IP address of 200.200.100.1/24, which acts as a static 
    IP address. The loopback interface points back to virtual-template1, which has a negotiated IP address. 
    !interface loopback 0
    ip address 200.200.100.1 255.255.255.0 (static IP address)
    ip nat outside!
    interface Virtual-Template1
    ip unnumbered loopback0no ip directed-broadcast
    ip nat outside
    !
    Verifying Configuration
    To verify that you have properly configured the loopback interface, enter the show interface loopback 
    command. You should see verification output similar to the following example.
    Router# show interface loopback 0Loopback0 is up, line protocol is up 
      Hardware is Loopback
      Internet address is 200.200.100.1/24  MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation LOOPBACK, loopback not set  Last input never, output never, output hang never
    CommandPurpose
    Step 1interface type number
    Example:
    Router(config)# interface Loopback 0
    Router(config-if)# 
    Enters configuration mode for the loopback 
    interface.
    Step 2ip address ip-address mask
    Example:
    Router(config-if)# ip address 10.108.1.1 
    255.255.255.0
    Router(config-if)# 
    Sets the IP address and subnet mask for the 
    loopback interface.
    Step 3exit
    Example:
    Router(config-if)# exitRouter(config)# 
    Exits configuration mode for the loopback 
    interface and returns to global configuration 
    mode. 
    						
    							 
    3-12
    Cisco 860 and Cisco 880 Series Integrated Services Routers Software Configuration Guide
    OL-xxxxx-xx
    Chapter 3      Basic Router Configuration
      Configuring Basic Parameters
      Last clearing of show interface counters never  Queueing strategy: fifo
      Output queue 0/0, 0 drops; input queue 0/75, 0 drops
      5 minute input rate 0 bits/sec, 0 packets/sec  5 minute output rate 0 bits/sec, 0 packets/sec
         0 packets input, 0 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 packets output, 0 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets     0 output buffer failures, 0 output buffers swapped out
    Another way to verify the loopback interface is to ping it:
    Router# ping 200.200.100.1 
    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
    Configuring Command-Line Access
    To configure parameters to control access to the router perform these steps, beginning in global 
    configuration mode:
    CommandPurpose
    Step 1line [aux | console | tty | vty] line-number 
    Example:
    Router(config)# line console 0
    Router(config-line)# 
    Enters line configuration mode, and specifies the 
    type of line.
    This example specifies a console terminal for 
    access.
    Step 2password password
    Example:
    Router(config)# password 5dr4Hepw3Router(config-line)# 
    Specifies a unique password for the console 
    terminal line.
    Step 3login
    Example:
    Router(config-line)# login
    Router(config-line)# 
    Enables password checking at terminal session 
    login.
    Step 4exec-timeout minutes [seconds]
    Example:
    Router(config-line)# exec-timeout 5 30
    Router(config-line)# 
    Sets the interval that the EXEC command 
    interpreter waits until user input is detected. The 
    default is 10 minutes. Optionally, add seconds to 
    the interval value.
    This example shows a timeout of 5 minutes and 
    30
     seconds. Entering a timeout of 0 0 specifies 
    never to time out. 
    						
    							 
    3-13
    Cisco 860 and Cisco 880 Series Integrated Services Routers Software Configuration Guide
    OL-xxxxx-xx
    Chapter 3      Basic Router Configuration
      Configuring Basic Parameters
    For complete information about the command line commands, see the Cisco IOS Release 12.4(15)XZ 
    documentation set. 
    Step 5line [aux | console | tty | vty] line-number 
    Example:
    Router(config-line)# line vty 0 4Router(config-line)# 
    Specifies a virtual terminal for remote console 
    access.
    Step 6password password
    Example:
    Router(config-line)# password aldf2ad1
    Router(config-line)#
    Specifies a unique password for the virtual 
    terminal line.
    Step 7login
    Example:
    Router(config-line)# login
    Router(config-line)# 
    Enables password checking at the virtual terminal 
    session login.
    Step 8end
    Example:
    Router(config-line)# end
    Router# 
    Exits line configuration mode, and returns to 
    privileged EXEC mode.
    Command Purpose 
    						
    							 
    3-14
    Cisco 860 and Cisco 880 Series Integrated Services Routers Software Configuration Guide
    OL-xxxxx-xx
    Chapter 3      Basic Router Configuration
      Configuring Static Routes
    Example
    The following configuration shows the command-line access commands.
    You do not need to input the commands marked “default.” These commands appear automatically in the 
    configuration file generated when you use the show running-config command.
    !line con 0
    exec-timeout 10 0
    password 4youreyesonlylogin
    transport input none (default)
    stopbits 1 (default)line vty 0 4
    password secret
    login!
    Configuring Static Routes
    Static routes provide fixed routing paths through the network. They are manually configured on the 
    router. If the network topology changes, the static route must be updated with a new route. Static routes 
    are private routes unless they are redistributed by a routing protocol.
    To configure static routes perform these steps, beginning in global configuration mode:
    For complete information on the static routing commands, see the Cisco IOS Release 12.4(15)XZ 
    documentation set. For more general information on static routing, see 
    Appendix B, “Floating Static 
    Routes.”
    CommandPurpose
    Step 1ip route prefix mask {ip-address | interface-type 
    interface-number [ip-address]} 
    Example:
    Router(config)# ip route 192.168.1.0 
    255.255.0.0 10.10.10.2
    Router(config)# 
    Specifies the static route for the IP packets.
    For details about this command and about 
    additional parameters that can be set, see the 
    Cisco 
    IOS IP Command Reference, Volume 2 of 4: 
    Routing Protocols.
    Step 2end
    Example:
    Router(config)# end
    Router# 
    Exits router configuration mode, and enters 
    privileged EXEC mode. 
    						
    							 
    3-15
    Cisco 860 and Cisco 880 Series Integrated Services Routers Software Configuration Guide
    OL-xxxxx-xx
    Chapter 3      Basic Router Configuration
      Configuring Dynamic Routes
    Example
    In the following configuration example, the static route sends out all IP packets with a destination IP 
    address of 192.168.1.0 and a subnet mask of 255.255.255.0 on the Fast Ethernet interface to another 
    device with an IP address of 10.10.10.2. Specifically, the packets are sent to the configured PVC.
    You do not need to enter the command marked “(default).” This command appears automatically in the 
    configuration file generated when you use the show running-config command.
    !ip classless (default)
    ip route 192.168.1.0 255.255.255.0 10.10.10.2!
    Verifying Configuration
    To verify that you have properly configured static routing, enter the show ip route command and look 
    for static routes signified by the “S.” 
    You should see verification output similar to the following:
    Router# show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2       ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    Gateway of last resort is not set
         10.0.0.0/24 is subnetted, 1 subnetsC       10.108.1.0 is directly connected, Loopback0
    S* 0.0.0.0/0 is directly connected, FastEthernet0
    Configuring Dynamic Routes
    In dynamic routing, the network protocol adjusts the path automatically, based on network traffic or 
    topology. Changes in dynamic routes are shared with other routers in the network.
    The Cisco routers can use IP routing protocols, such as Routing Information Protocol (RIP) or Enhanced 
    Interior Gateway Routing Protocol (EIGRP), to learn routes dynamically. You can configure either of 
    these routing protocols on your router. 
    						
    							 
    3-16
    Cisco 860 and Cisco 880 Series Integrated Services Routers Software Configuration Guide
    OL-xxxxx-xx
    Chapter 3      Basic Router Configuration
      Configuring Routing Information Protocol
    Configuring Routing Information Protocol
    To configure the RIP routing protocol on the router perform these steps, beginning in global 
    configuration mode:
    For complete information on the dynamic routing commands, see the Cisco IOS Release 12.4(15)XZ 
    documentation set. For more general information on RIP, see 
    Appendix B, “RIP.” 
    CommandTa s k
    Step 1router rip
    Example:
    Router> configure terminalRouter(config)# router rip
    Router(config-router)# 
    Enters router configuration mode, and enables RIP 
    on the router.
    Step 2version {1 | 2}
    Example:
    Router(config-router)# version 2Router(config-router)# 
    Specifies use of RIP version 1 or 2.
    Step 3network ip-address
    Example:
    Router(config-router)# network 192.168.1.1
    Router(config-router)# network 10.10.7.1
    Router(config-router)# 
    Specifies a list of networks on which RIP is to be 
    applied, using the address of the network of each 
    directly connected network.
    Step 4no auto-summary
    Example:
    Router(config-router)# no auto-summary
    Router(config-router)# 
    Disables automatic summarization of subnet routes 
    into network-level routes. This allows subprefix 
    routing information to pass across classful network 
    boundaries.
    Step 5end
    Example:
    Router(config-router)# endRouter# 
    Exits router configuration mode, and enters 
    privileged EXEC mode. 
    						
    							 
    3-17
    Cisco 860 and Cisco 880 Series Integrated Services Routers Software Configuration Guide
    OL-xxxxx-xx
    Chapter 3      Basic Router Configuration
      Configuring Enhanced Interior Gateway Routing Protocol
    Example
    The following configuration example shows RIP version 2 enabled in IP network 10.0.0.0 and 
    192.168.1.0.
    To see this configuration, use the show running-config command from privileged EXEC mode.
    !Router# show running-config
    router rip
     version 2 network 10.0.0.0
     network 192.168.1.0
     no auto-summary!
    Verifying Configuration
    To verify that you have properly configured RIP, enter the show ip route command and look for RIP 
    routes signified by “R.” You should see a verification output like the example shown below. 
    Router# show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2       E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route       o - ODR, P - periodic downloaded static route
    Gateway of last resort is not set
         10.0.0.0/24 is subnetted, 1 subnets
    C       10.108.1.0 is directly connected, Loopback0R    3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0/0
    Configuring Enhanced Interior Gateway Routing Protocol
    To configure Enhanced Interior Gateway Routing Protocol GRP (EGRP) perform these steps, beginning 
    in global configuration mode:
    CommandPurpose
    Step 1router eigrp as-number
    Example:
    Router(config)# router eigrp 109
    Router(config)# 
    Enters router configuration mode, and enables 
    EIGRP on the router. The autonomous-system 
    number identifies the route to other EIGRP routers 
    and is used to tag the EIGRP information. 
    						
    							 
    3-18
    Cisco 860 and Cisco 880 Series Integrated Services Routers Software Configuration Guide
    OL-xxxxx-xx
    Chapter 3      Basic Router Configuration
      Configuring Enhanced Interior Gateway Routing Protocol
    For complete information on the IP EIGRP commands, see the Cisco IOS Release 12.4(15)XZ 
    documentation set. For more general information on EIGRP concepts, see 
    Appendix B, “Enhanced 
    IGRP.”
    Example
    The following configuration example shows the EIGRP routing protocol enabled in IP networks 
    192.145.1.0 and 10.10.12.115. The EIGRP autonomous system number is 109.
    To see this configuration use the show running-config command, beginning in privileged EXEC mode.
    !router eigrp 109
    network 192.145.1.0
    network 10.10.12.115!
    Verifying Configuration
    To verify that you have properly configured IP EIGRP, enter the show ip route command, and look for 
    EIGRP routes indicated by “D.” You should see verification output similar to the following:
    Router# show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    Gateway of last resort is not set
         10.0.0.0/24 is subnetted, 1 subnets
    C       10.108.1.0 is directly connected, Loopback0
    D    3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0
    Step 2network ip-address
    Example:
    Router(config)# network 192.145.1.0Router(config)# network 10.10.12.115
    Router(config)# 
    Specifies a list of networks on which EIGRP is to 
    be applied, using the IP address of the network of 
    directly connected networks.
    Step 3end
    Example:
    Router(config-router)# endRouter# 
    Exits router configuration mode, and enters 
    privileged EXEC mode.
    Command Purpose 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 860, 880 Series User Manual