Home > Cisco Systems > Router > Cisco Systems Router 1800 Series User Manual

Cisco Systems Router 1800 Series User Manual

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Systems Router 1800 Series User Manual online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 3 Cisco Systems manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    							 
    PART 1
    Getting Started 
    						
    							CH A P T E R
     
    1-1
    Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
    OL-6426-02
    1
    Basic Router Configuration
    This chapter provides procedures for configuring the basic parameters of your Cisco router, including 
    global parameter settings, routing protocols, interfaces, and command-line access. It also describes the 
    default configuration on startup. Note that individual router models may not support every feature 
    described throughout this guide. Features not supported by a particular router are indicated whenever 
    possible.
    This chapter contains the following sections:
     Interface Port Labels
     Viewing the Default Configuration
     Information Needed for Configuration
     Configuring Basic Parameters
     Configuring Static Routes
     Configuring Dynamic Routes
     Configuring Enhanced IGRP
    Each section includes a configuration example and verification steps, as available.
    For complete information on how to access global configuration mode, see the “Entering Global 
    Configuration Mode” section in Appendix A, “Cisco IOS Basic Skills.” For more information on the 
    commands used in the following tables, see the Cisco IOS Release 12.3 documentation set.
    Interface Port Labels
    Ta b l e 1 lists the interfaces supported for each router and their associated port labels on the equipment.
    Ta b l e 1 Supported Interfaces and Associated Port Labels by Cisco Router 
    RouterInterfacePort Label
    Cisco 1801Fast Ethernet LANs SWITCH and FE8–FE5 (top), FE x and 
    FE4–FE1 (bottom)
    Fast Ethernet WANsFE0
    AT M  WA NADSLoPOTS
    Wireless LANLEFT, RIGHT/PRIMARY
    BRIISDN S/T 
    						
    							 
    1-2
    Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
    OL-6426-02
    Chapter 1      Basic Router Configuration
      Viewing the Default Configuration
    Viewing the Default Configuration
    When you first boot up your Cisco router, some basic configuration has already been performed. All of 
    the LAN and WAN interfaces have been created, console and VTY ports are configured, and the inside 
    interface for Network Address Translation has been assigned. Use the show
     running-config command 
    to view the initial configuration, as shown in 
    Example 1.
    NoteIf you are unable to view the initial configuration and you get a No Password Set error message, you 
    must reset the initial password.  For details, see the 
    “Recovering a Lost Password” section in Chapter 14, 
    “Troubleshooting”.
    Cisco 1802Fast Ethernet LANs SWITCH and FE8–FE5 (top), FE x and 
    FE4–FE1 (bottom)
    Fast Ethernet WANsFE0
    AT M  WA NADSLoISDN
    Wireless LANLEFT, RIGHT/PRIMARY
    BRIISDN S/T
    Cisco 1803Fast Ethernet LANs SWITCH and FE8–FE5 (top), FE x and 
    FE4–FE1 (bottom)
    Fast Ethernet WANsFE0
    AT M  WA NG.SHDSL
    Wireless LANLEFT, RIGHT/PRIMARY
    BRIISDN S/T
    Cisco 1811Fast Ethernet LANs SWITCH and FE9–FE6 (top), FE x and 
    FE5–FE2 (bottom)
    Fast Ethernet WANsFE0–FE1
    Wireless LANLEFT, RIGHT/PRIMARY
    USB1–0
    V. 9 2  MODEM
    Cisco 1812Fast Ethernet LANs SWITCH and FE9–FE6 (top), FE x and 
    FE5–FE2 (bottom)
    Fast Ethernet WANsFE0–FE1
    Wireless LANLEFT, RIGHT/PRIMARY
    BRIISDN S/T
    USB1–0
    Table 1 Supported Interfaces and Associated Port Labels by Cisco Router (continued)
    Router Interface Port Label 
    						
    							 
    1-3
    Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
    OL-6426-02
    Chapter 1      Basic Router Configuration
      Viewing the Default Configuration
    Example 1 Cisco 1812 Default Configuration on Startup
    version 12.3
    service timestamps debug datetime msecservice timestamps log datetime msec
    no service password-encryption
    !hostname Router
    !
    boot-start-markerboot-end-marker
    !
    mmi polling-interval 60no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180no aaa new-model
    ip subnet-zero
    !ip cef
    !
    ip ips po max-events 100no ftp-server write-enable
    !
    interface BRI0
     no ip address shutdown
    !
    interface FastEthernet0 no ip address
     shutdown
     duplex auto speed auto
    !
    interface FastEthernet1 no ip address
     shutdown
     duplex auto speed auto
    !
    interface FastEthernet2 no ip address
     shutdown
    !interface FastEthernet3
     no ip address
     shutdown!
    interface FastEthernet4
     no ip address shutdown
    !
    interface FastEthernet5 no ip address
     shutdown
    !interface FastEthernet6
     no ip address
     shutdown!
    interface FastEthernet7
     no ip address shutdown
    ! 
    						
    							 
    1-4
    Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
    OL-6426-02
    Chapter 1      Basic Router Configuration
      Information Needed for Configuration
    interface FastEthernet8 no ip address
     shutdown
    !interface FastEthernet9
     no ip address
     shutdown!
    interface Vlan1
     no ip address!
    ip classless
    !no ip http server
    no ip http secure-server
    !control-plane
    !
    line con 0line aux 0
    line vty 0 4
    !no scheduler allocate
    end
    Information Needed for Configuration
    You need to gather some or all of the following information, depending on your planned network 
    scenario, prior to configuring your network
     If you are setting up an Internet connection, gather the following information:
     –Point-to-Point Protocol (PPP) client name that is assigned as your login name
     –PPP authentication type: Challenge Handshake Authentication Protocol (CHAP) or Password 
    Authentication Protocol (PAP)
     –PPP password to access your Internet service provider (ISP) account
     –DNS server IP address and default gateways
     If you are setting up a connection to a corporate network, you and the network administrator must 
    generate and share the following information for the WAN interfaces of the routers:
     –PPP authentication type: CHAP or PAP
     –PPP client name to access the router
     –PPP password to access the router
     If you are setting up IP routing:
     –Generate the addressing scheme for your IP network.
     –Determine the IP routing parameter information, including IP address, and ATM permanent 
    virtual circuits (PVCs). These PVC parameters are typically virtual path identifier (VPI), virtual 
    circuit identifier (VCI), and traffic shaping parameters.
     –Determine the number of PVCs that your service provider has given you, along with their VPIs 
    and VCIs.
     –For each PVC determine the type of AAL5 encapsulation supported. It can be one of the 
    following: 
    						
    							 
    1-5
    Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
    OL-6426-02
    Chapter 1      Basic Router Configuration
      Configuring Basic Parameters
    AAL5SNAP—This can be either routed RFC 1483 or bridged RFC 1483. For routed RFC 1483, 
    the service provider must provide you with a static IP address. For bridged RFC 1483, you may 
    use DHCP to obtain your IP address, or you may obtain a static IP address from your service 
    provider.
    AAL5MUX PPP—With this type of encapsulation, you need to determine the PPP-related 
    configuration items.
     If you plan to connect over an ADSL or G.SHDSL line:
     –Order the appropriate line from your public telephone service provider. 
    For ADSL lines—Ensure that the ADSL signaling type is DMT (also called ANSI T1.413) or 
    DMT Issue 2. 
    For G.SHDSL lines—Verify that the G.SHDSL line conforms to the ITU G.991.2 standard and 
    supports Annex A (North America) or Annex B (Europe).
    Once you have collected the appropriate information, you can perform a full configuration on 
    your router, beginning with the tasks in the 
    “Configuring Basic Parameters” section.
    Configuring Basic Parameters
    To configure the router, perform one or more of these tasks:
     Configure Global Parameters
     Configure Fast Ethernet LAN Interfaces
     Configure WAN Interfaces
     Configuring a Loopback Interface
     Configuring Command-Line Access to the Router
    A configuration example is presented with each task to show the network configuration following 
    completion of that task. 
    						
    							
     
    1-6
    Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
    OL-6426-02
    Chapter 1      Basic Router Configuration
      Configuring  Basic Parameters
    Configure Global Parameters
    Perform these steps to configure select ed global parameters for your router:
    CommandPurpose
    Step 1configure terminal
    Example:
    Router> enable
    Router# configure terminal
    Router(config)# 
    Enters global configuration mode, when using the 
    console port.
    If you are connecting to the router using a remote 
    terminal, use the following:
    telnet router name or addressLogin: login id
    Password: *********
    Router> enable
    Step 2hostname  name
    Example:
    Router(config)#  hostname Router
    Router(config)# 
    Specifies the name for the router.
    Step 3enable secret password
    Example:
    Router(config)#  enable secret cr1ny5hoRouter(config)# 
    Specifies an encrypted password to prevent 
    unauthorized access to the router.
    Step 4no ip domain-lookup
    Example:
    Router(config)# no ip domain-lookup 
    Router(config)# 
    Disables the router from translating unfamiliar 
    words (typos) into IP addresses.
    For complete information on the global parameter commands, see the Cisco IOS Release 12.3 
    documentation set. 
    Configure Fast Ethernet LAN Interfaces
    The Fast Ethernet LAN interfaces on your router are automatically configured as part of the default 
    VLAN and as such, they are not configured with individual addresses. Access is afforded through the 
    VLAN. You may assign the interfaces to other VLANs  if desired. For more information about creating 
    VLANs, see 
    Chapter 5, “Configuring a LAN with DHCP and VLANs.” 
    						
    							
     
    1-7
    Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
    OL-6426-02
    Chapter 1      Basi c Router Configuration
      Configuring Basic Parameters
    Configure WAN Interfaces
    The Cisco 1811 and Cisco 1812 routers each have two Fast Ethernet interfaces for WAN connection. The 
    Cisco
     1801, Cisco 1802, and Cisco 1803 routers each have one ATM interface for WAN connection.
    Based on the router model you have, configure the WAN interface(s) using one of the following 
    procedures:
     Configure the Fast Ethernet WAN Interface
     Configure the ATM WAN Interface
    Configure the Fast Ethernet WAN Interface
    This procedure applies only to the Cisco 1811 and Cisco 1812 router models. Perform these steps to 
    configure the Fast Ethernet interfaces, beginning in global configuration mode.
    CommandPurpose
    Step 1interface  type number
    Example:
    Router(config)# interface fastethernet 0
    Router(config-int)# 
    Enters the configuration mode for a Fast 
    Ethernet WAN interface on the router.
    NoteFast Ethernet WAN ports are numbered 
    0–1 on the Cisco
     1800 series routers.
    Step 2ip address  ip-address mask
    Example:
    Router(config-int)#  ip address 192.1.12.2 
    255.255.255.0
    Router(config-int)# 
    Sets the IP address an d subnet mask for the 
    specified Fast Ethernet interface.
    Step 3no shutdown
    Example:
    Router(config-int)#  no shutdown
    Router(config-int)# 
    Enables the Ethernet interface, changing its 
    state from administratively down to 
    administratively up.
    Step 4exit
    Example:
    Router(config-int)#  exitRouter(config)# 
    Exits interface configuration mode and returns 
    to global configuration mode.
    Repeat these steps for the other Fast  Ethernet WAN interface if desired. 
    						
    							
     
    1-8
    Cisco 1800 Series Integrated Services Routers (Fixed) Software Configuration Guide
    OL-6426-02
    Chapter 1      Basic Router Configuration
      Configuring  Basic Parameters
    Configure the ATM WAN Interface
    This procedure applies only to the Cisco 1801, Cisco 1802, and Cisco 1803 models.
    Perform these steps to configure the ATM interface, beginning in global configuration mode:
    CommandPurpose
    Step 1For the Cisco 1803 only:
    controller dsl 0 
    mode atm 
    exit
    Example:
    Router(config)#  controller dsl 0
    Router(config-controller)#  mode atm
    Router(config-controller)# exitRouter(config)# 
    For routers using the G.SHDSL signaling, perform 
    these commands. Ignore this step for routers using 
    ADSL signaling.
    Step 2interface type number
    Example:
    Router(config)#  interface atm0
    Router(config-int)# 
    Enters interface configuration mode. 
    Step 3ip address ip-address mask
    Example:
    Router(config-int)#  ip address 
    200.200.100.1 255.255.255.0
    Router(config-int)# 
    Sets the IP address and  subnet mask for the ATM 
    interface.
    Step 4no shutdown
    Example:
    Router(config-int)#  no shutdownRouter(config-int)# 
    Enables the ATM 0 interface.
    Step 5exit
    Example:
    Router(config-int)# exit
    Router(config)# 
    Exits interface configuration mode and returns to 
    global configuration mode.
      
    						
    All Cisco Systems manuals Comments (0)