Home > Cisco > Router > Cisco Router 800 Series Software Configuration Guide

Cisco Router 800 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 800 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    Page
    of 600
    							 
    2-23
    Cisco 800 Series Software Configuratio Guide
    78-5372-06
    Chapter 2      Configuring Basic Networks
    Connecting a Remote Office to a Corporate Office
    Features Used
    This network uses the following features on the LAN:
    IP routing (Cisco recommends this for management purposes, such as Telnet)
    DHCP server (optional)
    When your router is acting as a DHCP server, workstations configured as DHCP 
    clients are automatically assigned an IP address and subnet mask. 
    This network uses the following features on the WAN:
    IP routing
    PPP
    IPCP
    CHAP or PAP over PPP
    DDR
    Static routes
    With IPCP configured, your router automatically negotiates its IP address from 
    the router it is attempting to connect.
    You can use either CHAP or PAP as the PPP authentication protocol. Cisco 
    recommends using CHAP because it is the more secure of the two protocols.
    Because DDR is configured, the ISDN line is activated only when needed using 
    one route that has been manually configured (static route). Because a static route 
    is configured, the routers do not need to exchange routing updates. As a result, the 
    ISDN line is activated only when traffic demands. 1Site 165ESS custom multipoint switch type, with B1 
    SPID 0155533330101 / B2 SPID 
    0155544440101
    27Site 2
    38IP network at Site 2
    49File server at Site 2
    5ISDN network connection 
    						
    							 
    Chapter 2      Configuring Basic Networks
    Connecting a Remote Office to a Corporate Office
    2-24
    Cisco 800 Series Software Configuratio Guide
    78-5372-06
    Cisco 800 Series Router Configuration
    To configure the features for this network example, perform the following steps 
    on the PC, starting in the global configuration prompt.
    Step 1Specify a name for the router. For example:
    router(config)# hostname SanJose
    Step 2Specify an encrypted password. For example:
    SanJose(config)# enable secret password
    Step 3Specify the username of any client that will potentially dial into your router and 
    the password that your router and the client will share. Specify the username and 
    password of the central office router (the central office network administrator 
    should provide this information). For example: 
    SanJose(config)# username LosAngeles password gocisco1
    Step 4Optional. Configure your router as a DHCP server:
    a.Define the DHCP relay pool name. For example:
    router(config)# ip dhcp pool DHCPpoolLAN_0
    b.Set the DHCP pool of addresses. For example:
    router(dhcp-config)# network 10.1.0.0 255.255.0.0
    c.Set the IP addresses of the DNS servers. For example:
    router(dhcp-config)# dns-server 192.168.1.0 255.255.255.0
    d.Set the Ethernet 0 IP address as the default gateway. For example:
    router(dhcp-config)# default-router 10.1.0.1
    Step 5Configure the WAN interface by performing the following steps:
    a.Change to global configuration mode:
    SanJose(dhcp-config)# exit
    SanJose(config)#
    b.Specify parameters for the WAN interface:
    SanJose(config)# interface bri0
    SanJose(config-if)#  
    						
    							 
    2-25
    Cisco 800 Series Software Configuratio Guide
    78-5372-06
    Chapter 2      Configuring Basic Networks
    Connecting a Remote Office to a Corporate Office
    c.Enable PPP:
    SanJose(config-if)# encapsulation ppp
    d.Enable multilink PPP:
    SanJose(config-if)# ppp multilink
    e.Create a dialer rotary group, specifying a number between 0 and 255. Dialer 
    rotary groups are useful in environments that require multiple calling 
    destinations. For example:
    SanJose(config-if)# dialer rotary-group 0
    f.North America only. Associate the ISDN local directory numbers (LDNs) 
    provided by your telephone service provider to the first and second SPIDs. 
    You can specify the SPID number or you can have it automatically detected 
    by entering a 0.
    In the following example, the SPID number is represented by a 0 so that it 
    would be automatically detected. The primary LDN is followed by the 
    secondary LDN for each SPID.
    SanJose(config-if)# isdn spid1 0 4085551111 4085552222
    SanJose(config-if)# isdn spid2 0 4085553333 4085554444
    NoteFind out from your telephone service provider whether you need to 
    specify an area code for the LDN.
    g.North America only. If you had entered the SPID number, enable the BRI0 
    interface.
    SanJose(config-if)# no shutdown
    h.North America only. If you configured the SPID to be automatically detected, 
    enable the automatic detection of ISDN SPID numbers and switch type:
    SanJose(config-if)# isdn autodetect
    i.Outside of North America only. Specify the ISDN switch type. To see a 
    listing of supported switches, enter the isdn switch-type ? command. 
    The following example specifies the NET3 switch:
    SanJose(config-if)# isdn switch-type basic-net3 
    						
    							 
    Chapter 2      Configuring Basic Networks
    Connecting a Remote Office to a Corporate Office
    2-26
    Cisco 800 Series Software Configuratio Guide
    78-5372-06
    j.Disable CDP.
    SanJose(config-if)# no cdp enable
    Step 6Specify the characteristics of the dialer rotary group that you created earlier by 
    performing the following steps:
    a.Change to global configuration mode:
    SanJose(config-if)# exit
    SanJose(config)#
    b.Create a virtual interface by specifying a number between 0 to 255 to 
    represent your dialer rotary group.
    SanJose(config)# interface dialer 0
    c.Enable PPP:
    SanJose(config-if)# encapsulation ppp
    d.Enable DDR:
    SanJose(config-if)# dialer in-band
    e.Specify the amount of time (in seconds) that the line can be idle before it is 
    disconnected. For example:
    SanJose(config-if)# dialer idle-timeout 300
    f.Set the number of packets to be held in the outgoing queue to 10. If an ISDN 
    connection does not exist yet, the hold-queue holds up to 10 packets before 
    dropping them. For example:
    SanJose(config-if)# dialer hold-queue 10
    g.Define the load level that must be exceeded on the first ISDN B channel 
    before the second B channel is brought up. The load-threshold variable 
    represents a utilization percentage and is a number between 1 and 255, where 
    255 equals 100 percent. 
    SanJose(config-if)# dialer load-threshold 150 outbound 
    						
    							 
    2-27
    Cisco 800 Series Software Configuratio Guide
    78-5372-06
    Chapter 2      Configuring Basic Networks
    Connecting a Remote Office to a Corporate Office
    NoteEnter outbound to calculate the load using outbound data only, 
    inbound to calculate the load using inbound data only, and either to 
    set the maximum calculated load as the larger of the outbound and 
    inbound loads.
    h.Assign this interface to dialer access group 1:
    SanJose(config-if)# dialer-group 1
    i.Configure CHAP. To configure PAP, skip this step, and go on to the next 
    step. This command enables CHAP and specifies authentication on incoming 
    and outgoing calls.
    SanJose(config-if)# ppp authentication chap
    j.Configure PAP. To configure CHAP, skip this step, and go to the previous 
    step. This command enables PAP and specifies authentication on incoming 
    and outgoing calls.
    SanJose(config-if)# ppp authentication pap
    k.Enable multilink PPP, then return to global configuration mode:
    SanJose(config-if)# ppp multilink
    SanJose(config-if)# exit
    Step 7Perform this step only if ISDN calls at 64 kbps are not supported on your line. 
    Specify the characteristics of outgoing calls from an ISDN interface by 
    performing the following steps:
    a.Define a class of shared configuration parameters for outgoing calls from an 
    ISDN interface:
    SanJose(config)# interface dialer 0
    SanJose(config-if)# dialer string 5551212 class 56k
    SanJose(config-if)# exit
    SanJose(config)# map-class dialer 56k
    b.Specify 56 kbps as the B channel speed:
    SanJose(config-map-class)# dialer isdn speed 56
    c.Change to global configuration mode:
    SanJose(config-map-class)# exit
    SanJose(config)# 
    						
    							 
    Chapter 2      Configuring Basic Networks
    Connecting a Remote Office to a Corporate Office
    2-28
    Cisco 800 Series Software Configuratio Guide
    78-5372-06
    Step 8If you have a Cisco 800 series router that is connected to a telephone, fax 
    machine, or modem, configure the telephone interface by performing the 
    following steps:
    a.Specify the country where your router is located. For example:
    SanJose(config)# pots country us
    This command determines the physical characteristics of the telephone 
    interfaces. By specifying a country, you are configuring your telephone to use 
    country-specific default settings for each of the physical characteristics. To 
    get a list of supported countries and the code, enter the pots country ? 
    command.
    b.Create dial peers to determine how incoming calls are routed to the telephone 
    ports. In the following example, the dial-peer tag is 1, the ISDN local 
    directory number (LDN) is 5551111, the telephone port is 1, and call waiting 
    is disabled:
    SanJose(config)# dial-peer voice 1 pots
    SanJose(config-dial-peer)# destination-pattern 5551111
    SanJose(config-dial-peer)# port 1
    SanJose(config-dial-peer)# no call-waiting
    SanJose(config-dial-peer)# exit
    SanJose(config)#
    NoteFind out from your telephone service provider whether you need to 
    specify an area code for the LDN.
    c.Specify parameters for the WAN interface:
    SanJose(config)# interface bri0
    d.Specify that incoming voice calls are forwarded to the devices connected to 
    the telephone ports:
    SanJose(config-if)# isdn incoming-voice modem 
    						
    							 
    2-29
    Cisco 800 Series Software Configuratio Guide
    78-5372-06
    Chapter 2      Configuring Basic Networks
    Connecting a Remote Office to a Corporate Office
    IP Routing Configuration
    To configure IP routing, perform the following steps on your PC:
    Step 1Change to global configuration mode:
    SanJose(config-if)# exit
    SanJose(config)#
    Step 2Configure the router to recognize the zero subnet range as a valid range of 
    addresses:
    SanJose(config)# ip subnet-zero
    Step 3Disable the router from translating unfamiliar words entered during a console 
    session into IP addresses:
    SanJose(config)# no ip domain-lookup
    Step 4Configure the LAN interface by performing the following steps:
    a.Specify parameters for the LAN interface:
    SanJose(config)# interface ethernet0
    b.Set an IP address and subnet mask for the LAN interface. For example:
    SanJose(config)# ip address 10.1.0.1 255.255.0.0
    Step 5Follow these steps to specify characteristics of the dialer rotary groups that were 
    created earlier:
    a.Specify parameters for the dialer rotary group:
    SanJose(config)# interface bri0
    b.Specify the IP address under the dialer group 1:
    SanJose(config-if)# dialer-group 1
    SanJose(config-if)# ip address 10.3.1.1 255.255.0.0
    c.Specify that there are no IP addresses assigned for this interface:
    SanJose(config-if)# no ip address
    SanJose(config-if)#  
    						
    							 
    Chapter 2      Configuring Basic Networks
    Connecting a Remote Office to a Corporate Office
    2-30
    Cisco 800 Series Software Configuratio Guide
    78-5372-06
    d.To configure the WAN interface to call a site or to receive calls from a site, 
    create a dialer map. In the following example, the same command is entered 
    twice, once for each dial string provided for the two B channels. The next hop 
    address is 10.3.1.2, and the host name is LosAngeles in both entries.
    SanJose(config-if)# dialer map ip 10.3.1.2 
    name LosAngeles speed 56 14085553333
    SanJose(config-if)# dialer map ip 10.3.1.2 
    name LosAngeles speed 56 14085554444
    Step 6Follow these steps to configure how the IP routing protocol learns the routes:
    a.Change to global configuration mode:
    SanJose(config-if)# exit
    SanJose(config)#
    b.Configure all IP addresses to be treated as IP classless addresses:
    SanJose(config)# ip classless
    c.Set up static routes. In the following example, the LosAngeles local network 
    is 10.2.0.0, the subnet mask is 255.255.0.0, and the router ISDN interface is 
    10.2.0.1:
    SanJose(config)# ip route 10.2.0.0 255.255.0.0 10.2.1.2
    NoteYou must configure the route to the LosAngeles network as well as 
    the route to the LosAngeles router ISDN interface. The route to the 
    LosAngeles router is through the dialer 0 port of the SanJose router.
    Step 7Specify that dialer-list 1 permits dialing by the IP routing protocol:
    SanJose(config)# dialer-list 1 protocol ip permit 
    						
    							 
    2-31
    Cisco 800 Series Software Configuratio Guide
    78-5372-06
    Chapter 2      Configuring Basic Networks
    Connecting a Remote Office to a Corporate Office
    Corporate Router Configuration
    To configure the features for this sample network, perform the following steps on 
    your PC from global configuration mode. This section assumes that the router 
    connected to the Cisco 800 series router is a Cisco router that supports Cisco IOS 
    software, for example, a Cisco 3600 router. For more information, refer to the 
    documentation that accompanied your other Cisco router.
    Step 1Specify a name for the router; for example, LosAngeles:
    router# hostname LosAngeles
    Step 2Specify an encrypted password, for example, abra cadabra:
    LosAngeles# enable secret abra cadabra
    Step 3Specify the username of any client that will potentially dial in to your router and 
    the password that your router and the client will share. The following example 
    specifies SanJose and gocisco1 as the username and password:
    LosAngeles# username SanJose password gocisco1
    Step 4Change to global configuration, then to interface configuration mode. Specify the 
    ISDN switch type. To get a listing of supported switches, enter the isdn 
    switch-type ? command.
    LosAngeles# configure terminal
    LosAngeles(config)# interface bri0
    LosAngeles(config-if)# isdn switch-type basic-net3
    To specify a National ISDN-1 (NI1) switch, enter the following:
    LosAngeles(config)# isdn switch-type basic-ni1
    Step 5Optional. Configure your router as a DHCP server:
    a.Define the DHCP relay pool name. For example:
    LosAngeles(config)# ip dhcp pool DHCPpoolLAN_0
    b.Set the DHCP pool of addresses. For example:
    LosAngeles(dhcp-config)# network 10.2.0.0 255.255.0.0
    c.Set the IP addresses of the DNS servers. For example:
    LosAngeles(dhcp-config)# dns-server 172.29.20.41 172.29.20.51 
    						
    							 
    Chapter 2      Configuring Basic Networks
    Connecting a Remote Office to a Corporate Office
    2-32
    Cisco 800 Series Software Configuratio Guide
    78-5372-06
    d.Set the Ethernet 0 IP address as the default gateway. For example:
    LosAngeles(dhcp-config)# default-router 10.2.0.1
    e.Exit to global configuration mode.
    LosAngeles(dhcp-config)# exit
    Step 6Configure the WAN interface by performing the following steps:
    a.Specify parameters for the WAN interface:
    LosAngeles(config)# interface bri0
    b.Enable PPP:
    LosAngeles(config-if)# encapsulation ppp
    c.Enable multilink PPP:
    LosAngeles(config-if)# ppp multilink
    d.Create a dialer rotary group, specifying a number between 0 and 255. Dialer 
    rotary groups are useful in environments that require multiple calling 
    destinations. For example:
    LosAngeles(config-if)# dialer rotary-group 0
    e.North America only. Specify the SPID numbers assigned to your B channels, 
    using the isdn spid1 command for the B1 channel and the isdn spid2 
    command for the B2 channel. For example:
    LosAngeles(config-if)# isdn spid1 0155533330101
    LosAngeles(config-if)# isdn spid2 0155544440101
    f.Disable CDP.
    LosAngeles(config-if)# no cdp enable
    Step 7Specify characteristics of the dialer rotary group created earlier by following 
    these steps:
    a.Change to global configuration mode:
    LosAngeles(config-if)# exit
    LosAngeles(config)#
    b.Create a dialer rotary group leader. Specify a number between 0 to 255 to 
    represent your dialer rotary group.
    LosAngeles(config)#interface dialer 0 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 800 Series Software Configuration Guide