Home > Cisco > Router > Cisco Router 800 Series Software Configuration Guide

Cisco Router 800 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 800 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    Page
    of 600
    							CHAPTER
     
    7-1
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    7
    Router Feature Configuration
    This chapter includes basic feature-by-feature configuration procedures for 
    Cisco 800 series and Cisco SOHO series routers. This chapter is useful if you 
    have a network in place and you want to add specific features.
    NoteEvery feature described is not necessarily supported on every router model. 
    Where possible and applicable, feature limitations are listed.
    If you prefer to use network scenarios to build a network, see Chapter 4, 
    “Network Scenarios.”
    This chapter contains the following sections:
    Before You Configure Your Network, page 7-2
    Configuring Basic Parameters, page 7-3
    Configuring Bridging, page 7-14
    Configuring Static Routing, page 7-17
    Configuring Dynamic Routing, page 7-18
    Configuring IP EIGRP, page 7-20
    Configuring Addressing Parameters, page 7-22
    Configuring DHCP, page 7-27
    Configuring TACACS+, page 7-33
    Configuring an Extended Access List, page 7-34
    Configuring Quality of Service Parameters, page 7-36 
    						
    							 
    Chapter 7      Router Feature Configuration
    Before You Configure Your Network
    7-2
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Configuring a Single-PVC Environment Using RFC 1483 Encapsulation, 
    page 7-40
    Configuring Dial Backup, page 7-53
    Configuring IGMP Proxy and Sparse Mode, page 7-60
    Configuring IP Security and GRE Tunneling, page 7-63
    Configuring Multilink PPP Fragmentation and Interleaving, page 7-70
    Configuring Voice, page 7-73
    Cisco 827 Router Configuration Examples, page 7-78
    Corporate or Endpoint Router Configuration for Data and Voice Network, 
    page 7-83
    Each section includes a configuration example and verification steps, where 
    available.
    Before You Configure Your Network
    Before you configure your network, you must do the following:
    If applicable, order an ADSL, G.SHDSL, or ISDN line from your telephone 
    service provider.
    Determine the number of PVCs that your service provider is giving you, 
    together with their virtual path identifiers (VPIs) and virtual channel 
    identifiers (VCIs).
    For each PVC determine the type of AAL5 encapsulation supported. It can be 
    one of the following:
    –AAL5SNAP: This can be either routed RFC 1483 or bridged RFC 1483. 
    In the case of routed RFC 1483, the service provider has to provide you 
    with a static IP address. In the case of bridged RFC 1483, you may use 
    DHCP to obtain your IP address or you may be given a static IP address 
    from your service provider.
    –AAL5MUX PPP: With this type, you need to determine PPP-related 
    configuration items. 
    						
    							 
    7-3
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring Basic Parameters
    If you are setting up an Internet connection, gather the following information: 
    –Point-to-Point Protocol (PPP) client name that is assigned as your login 
    name.
    –PPP authentication type: Challenge Handshake Authentication Protocol 
    (CHAP) or Password Authentication Protocol (PAP).
    –PPP password to access your Internet Service Provider (ISP) account.
    –DNS server IP address and default gateways.
    If you are setting up a connection to a corporate network, you and its network 
    administrator must generate and share the following information for the 
    WAN interfaces of the routers:
    –PPP authentication type: CHAP or PAP.
    –PPP client name to access the router.
    –PPP password to access the router.
    If you are setting up IP routing, generate the addressing scheme for your IP 
    network.
    Configuring Basic Parameters
    To configure the router, perform the tasks described in the following sections:
    Configuring Global Parameters
    Configuring the Ethernet Interface
    Configuring the Dialer Interface
    Configuring the Loopback Interface
    Configuring the Asynchronous Transfer Mode Interface
    Configuring Command-Line Access to the Router
    A configuration file example that illustrates how to configure the network is 
    presented after the tasks.
    After your router boots, the following prompt displays. Enter no.
    Would you like to enter the initial configuration dialog [yes]: no 
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring Basic Parameters
    7-4
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    For complete information on how to access global configuration mode, see the 
    “Entering Global Configuration Mode” section on page A-8. For more 
    information on the commands used in the following tables, refer to the Cisco IOS 
    Release 12.0 documentation set.
    Configuring Global Parameters
    Follow the steps below to configure the router for global parameters.
    For complete information on the global parameter commands, refer to the 
    Cisco IOS Release 12.0 documentation set. 
    Configuring the Ethernet Interface
    Follow the steps below to configure the Ethernet interface, beginning in global 
    configuration mode. Command Task
    Step 1configure terminalEnter configuration mode.
    Step 2hostname nameSpecify the name for the router.
    Step 3enable secret passwordSpecify an encrypted password to prevent 
    unauthorized access to the router.
    Step 4ip subnet-zeroConfigure the router to recognize zero subnet 
    range as valid range of addresses.
    Step 5no ip domain-lookupDisable the router from translating unfamiliar 
    words (typos) entered during a console 
    session into IP addresses.
    Command Task
    Step 1interface ethernet 0Enter configuration mode for the Ethernet 
    interface.
    Step 2ip address ip-address maskSet the IP address and subnet mask for the 
    Ethernet interface. 
    						
    							 
    7-5
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring Basic Parameters
    For complete information on the Ethernet commands, refer to the 
    Cisco IOS Release 12.0 documentation set. For more general information on 
    Ethernet concepts, see Chapter 1, “Concepts.”
    Configuration Example
    The following example shows the Ethernet interface configuration. You do not 
    need to enter the commands marked “default.” These commands appear 
    automatically in the configuration file that is generated when you use the show 
    running-config command.
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    no ip directed-broadcast (default)
    !
    Verifying Your Configuration
    To verify that you have properly configured the Ethernet interface, enter the show 
    interface ethernet0 command. You should see a verification output like the 
    example shown below. 
    router#sh int eth0
    Ethernet0 is up, line protocol is up
    Hardware is PQUICC Ethernet, address is 0000.Oc13.a4db 
    (bia0010.9181.1281)
    Internet address is 170.1.4.101/24
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, 
    reliability 255/255., txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Step 3no shutdownEnable the Ethernet interface to change the 
    state from administratively down to up.
    Step 4exitExit configuration mode for the Ethernet 
    interface. Command Task 
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring Basic Parameters
    7-6
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Configuring the Dialer Interface 
    Use these commands if you are using PPP encapsulation for the ATM PVC. 
    Follow the steps below to configure the dialer interface, beginning in global 
    configuration mode.
    Configuration Example
    The following example shows the dialer interface configuration. You do not need 
    to input the commands marked “default.” These commands appear automatically 
    in the configuration file that is generated when you use the show running-config 
    command.
    !
    interface atm0
    pvc 1/40
    encapsulation aal5mux ppp dialer
    Command Task
    Step 1interface dialer number  Enter configuration mode for the dialer 
    interface.
    Step 2encapsulation pppSpecify the encapsulation type for the PVC as 
    PPP.
    Step 3ip address ip-address maskSet the IP address and subnet mask for the 
    dialer interface.
    Step 4dialer pool numberSpecify which dialer pool number you are 
    using.
    Step 5pvc vpi/vciCreate an ATM PVC for each end node with 
    which the router communicates.
    Step 6encapsulation aal5mux ppp dialerSpecify the encapsulation type as AAL5MUX 
    PPP.
    Step 7dialer pool-member numberSpecify a dialer pool-member.
    Step 8dialer-group numberSpecify a dialer group. The dialer group is 
    required to fast-switch outgoing packets.
    Step 9exitExit configuration mode for the ATM 
    interface. 
    						
    							 
    7-7
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring Basic Parameters
    dialer pool-member 1
    !
    interface dialer 0
    ip address 200.200.100.1 255.255.255.0
    encapsulation ppp
    dialer pool 1
    !
    Verifying Your Configuration
    To verify that you have properly configured the dialer interface, enter the show 
    interface virtual-access 1 command. Both line protocol and dialer 0 should be up 
    and running. You should see a verification output like the example shown below.
    router(config-if)#sh int virtual-access 1
    Virtual-Access1 is up, line protocol is up 
    Hardware is Virtual Access interface
    Interface is unnumbered. Using address of Dialer0 (2.2.2.1)
    MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, loopback not set
    Virtual-access 1 is up means that the interface is up and running. If you see the 
    output Virtual-access 1 is down, it means that the interface is “administratively 
    down,” and the interface is configured with the shutdown command. To bring the 
    interface up, you must enter the no shutdown command.
    Configuring the Loopback Interface
    This section describes configuring the loopback interface. The loopback interface 
    acts as a placeholder for the static IP address and provides default routing 
    information.
    For complete information on the loopback commands, refer to the 
    Cisco IOS Release 12.0 documentation set.  
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring Basic Parameters
    7-8
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Configuration Tasks
    Follow the steps below to configure the loopback interface.
    Sample Configuration
    The loopback interface in this sample configuration is used to support NAT on the 
    virtual-template interface. This sample configuration shows the loopback 
    interface configured on the Ethernet interface with an IP address of 
    200.200.100.1/24, which acts as a static IP address. The loopback interface points 
    back to virtual-template1, which has a negotiated IP address. 
    !
    interface Loopback0
    ip address 200.200.100.1 255.255.255.0 (static IP address)
    ip nat outside
    !
    interface Virtual-Template1
    ip unnumbered loopback0
    no ip directed-broadcast
    ip nat outside
    !
    Command Task
    Step 1interface Loopback 0 Enter configuration mode for the loopback 
    interface.
    Step 2ip address ip-address maskSet the IP address and subnet mask for the 
    loopback interface.
    Step 3ip  nat  outside Set the interface to be connected to the outside 
    network.
    Step 4exit Exit configuration mode for the loopback 
    interface. 
    						
    							 
    7-9
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring Basic Parameters
    Verifying Your Configuration
    To verify that you have properly configured the loopback interface, enter the 
    show interface loopback 0 command. You should see a verification output 
    similar to the following example.
    Router #sh int loopback 0
    Loopback0 is up, line protocol is up 
      Hardware is Loopback
      Internet address is 200.200.100.1/24
      MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation LOOPBACK, loopback not set
      Last input never, output never, output hang never
      Last clearing of show interface counters never
      Queueing strategy: fifo
      Output queue 0/0, 0 drops; input queue 0/75, 0 drops
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         0 packets input, 0 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 packets output, 0 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 output buffer failures, 0 output buffers swapped out
    Another way to verify the loopback interface is to send multiple ping packets to it:
    Router#ping 200.200.100.1 
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
    Configuring the Asynchronous Transfer Mode Interface
    Use the following steps to configure the Asynchronous Transfer Mode (ATM) 
    interface, beginning in global configuration mode. 
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring Basic Parameters
    7-10
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    NoteThe default service class for configuring the ATM interface is unspecified bit rate 
    (ubr). You can change the service class to variable bit rate non-real time (vbr-nrt) 
    or variable bit rate real time (vbr-rt) by using one of these commands: vbr-nrt or 
    vbr-rt. Refer to the Cisco IOS Release 12.0 documentation set. For more 
    information on definitions of service classes, see Chapter 1, “Concepts.” 
    Command Task
    Step 1interface ATM 0Enter configuration mode for the ATM 
    interface.
    Step 2dsl equipment-type {co | cpe} Configure the DSL equipment type, if 
    applicable.
    Step 3dsl linerate {number | auto} Specify the G.SHDSL line rate, if applicable. 
    The range of valid numbers is between 72 and 
    2312.
    Step 4dsl operating-mode gshdsl symmetric 
    annex annexSet the G.SHDSL operating mode, if 
    applicable, and select the G.991.2 annex.
    Step 5ip address ip-address maskSet the IP address and subnet mask for the 
    ATM interface.
    Step 6pvc vpi/vciCreate an ATM PVC for each end node with 
    which the router communicates.
    Step 7protocol ip ip-address broadcastSet the protocol broadcast for the IP address.
    Step 8encapsulation protocolSpecify the encapsulation type for the PVC. 
    Encapsulations can be specified as 
    AAL5SNAP, AAL5MUX IP, or AAL5MUX 
    PPP.
    1
    1. This step is optional. If you specify the AAL5MUX PPP encapsulation, you will need to add an additional step to specify the 
    dialer pool-member number using the command dialer-pool member number.
    Step 9tx-ring-limit numberConfigure the size of the PVC transmit queue. 
    The default setting is 6.
    Step 10no shutdownEnable the ATM interface.
    Step 11exitExit configuration mode for the ATM 
    interface. 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 800 Series Software Configuration Guide