Home > Cisco > Router > Cisco Router 800 Series Software Configuration Guide

Cisco Router 800 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 800 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    Page
    of 600
    							 
    4-43
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    ip address negotiated
    ip mtu 1492
    encapsulation ppp
    dialer pool 2
    dialer-group 2
    !
    ip classless
    no cdp enable
    !Primary and backup interface given route metric (This example using 
    static routes, thus atm0 line protcol must be brought down for backup 
    interface to function.)
    ip route 0.0.0.0 0.0.0.0 22.0.0.2
    ip route 0.0.0.0 0.0.0.0 192.168.2.2 150
    ip http server
    !
    !Specifies interesting traffic to trigger backup ISDN traffic
    dialer-list 1 protocol ip permit
    The following is an example of configuring dial backup and remote management 
    using dialer watch.
    Cisco836#
    !
    vpdn enable
    !
    vpdn-group 1
    accept-dialin
    protocol pppoe
    !
    !Specifies the ISDN switch type
    isdn switch-type basic-net3
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    hold-queue 100 out
    !
    !ISDN interface to be used as a backup interface
    interface BRI0
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-net3
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 1/40
    encapsulation aal5snap 
    						
    							 
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    4-44
    Cisco 800 Series Software Configuration Guide
    78-5372-06 pppoe-client dial-pool-number 2
    !
    dsl operating-mode auto
    !
    ! Dial backup interface, associated with physical BRI0 interface. 
    Dialer pool 1 associates it with BRI0’s dialer pool member 1. Note 
    “dialer watch-group 1” associates a watch list with corresponding 
    “dialer watch-list” command
    interface Dialer0
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 30
    dialer string 384040
    dialer watch-group 1
    dialer-group 1
    !
    ! Primary interface associated with physical ATM0 interface, dialer 
    pool 2 associates it with ATM0’s dial-pool-number2
    interface Dialer2
    ip address negotiated
    ip mtu 1492
    encapsulation ppp
    dialer pool 2
    dialer-group 2
    no cdp enable
    !
    ip classless
    !Primary and backup interface given route metric
    ip route 0.0.0.0 0.0.0.0 22.0.0.2
    ip route 0.0.0.0 0.0.0.0 192.168.2.2 80
    ip http server
    !
    !Watch for interesting traffic
    dialer watch-list 1 ip 22.0.0.2 255.255.255.255
    !Specifies interesting traffic to trigger backup ISDN traffic
    dialer-list 1 protocol ip permit
    ! 
    						
    							 
    4-45
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    Configuring the Aggregator and ISDN Peer Router
    The aggregator is typically a concentrator router where the Cisco 836 router ATM 
    PVC will terminate. In the configuration example shown below, the aggregator is 
    configured as a PPPoE server to correspond with the Cisco 836 router 
    configuration example that is given on page 4-41 and page 4-42.
    The ISDN peer router is any router that has an ISDN interface and can 
    communicate through a public ISDN network to reach the Cisco 836 router ISDN 
    interface. The ISDN peer router provides Internet access for the Cisco 836 router 
    during the ATM network downtime.
    The following is a configuration example of an aggregator used in the Cisco 836 
    router network. 
    !
    vpdn enable
    no vpdn logging
    !
    vpdn-group 1
    accept-dialin
    protocol pppoe
    virtual-template 1
    !
    interface Ethernet3
    description “4700ref-1”
    ip address 40.1.1.1 255.255.255.0
    media-type 10BaseT
    !
    interface Ethernet4
    ip address 30.1.1.1 255.255.255.0
    media-type 10BaseT
    !
    interface Virtual-Template1
    ip address 22.0.0.2 255.255.255.0
    ip mtu 1492
    peer default ip address pool adsl
    !
    interface ATM0
    no ip address
    pvc 1/40
    encapsulation aal5snap
    protocol pppoe
    !
    no atm limi-keepalive
    !
    ip local pool adsl 22.0.0.1 
    						
    							 
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    4-46
    Cisco 800 Series Software Configuration Guide
    78-5372-06 ip classless
    ip route 0.0.0.0 0.0.0.0 22.0.0.1 50
    ip route 0.0.0.0 0.0.0.0 30.1.1.2.80
    The following is a configuration example of an ISDN peer router used in the 
    Cisco 836 router network. 
    !
    isdn switch-type basic-net3
    !
    interface Ethernet0
    ip address 30.1.1.2 255.0.0.0 
    !
    interface BRI0
    description “to 836-dialbackup”
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-net3
    !
    interface Dialer0
    ip address 192.168.2.2 255.255.255.0
    encapsulation ppp
    dialer pool 1
    dialer string 384020
    dialer-group 1
    peer default ip address pool isdn
    !
    ip local pool isdn 192.168.2.1
    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.2.1
    ip route 40.0.0.0 255.0.0.0 30.1.1.1
    !
    dialer-list 1 protocol ip permit
    !
    Configuring Remote Management for the Cisco SOHO 97 Router
    Complete the following steps to configure remote management for the 
    Cisco SOHO 97 router. 
    						
    							 
    4-47
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    Configuration Example
    The following configuration example for a Cisco SOHO 97 router specifies the IP 
    address for the ATM interface via PPP/IPCP address and supports dial-in 
    maintenance over the console port. 
    !
    !Remote management account
    username dialin password cisco
    modemcap entry MY_USR_MODEM:MSC=&F1S0=1
    !
    interface Ethernet0
     ip address 192.168.1.1 255.255.255.0
     ip nat inside
     hold-queue 100 out
    !
    interface ATM0
     no ip address
     no atm ilmi-keepalive
     pvc 0/35 
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
     dsl operating-mode auto
    !
    interface Async1
     no ip address
     encapsulation ppp
     dialer in-band
    autodetect encapsulation ppp
     async default routing
    Command Task
    Step 1interface Async1Enter configuration mode for the async 
    interface.
    Step 2line con 0Enter configuration mode for the console 
    interface.
    Step 3modem enableChange the console port to the auxiliary port. 
    Step 4line aux 0Enter configuration mode for the auxiliary 
    interface.
    Step 5flowcontrol hardwareEnable hardware signal flow control. 
    						
    							 
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    4-48
    Cisco 800 Series Software Configuration Guide
    78-5372-06  async dynamic routing
     async mode dedicated
     pap authentication pap callin
    peer default ip address 192.168.2.2
    !
    ip nat inside source list 101 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1 150
    !
    no ip http server
    ip pim bidir-enable
    !
    !
    access-list 101 permit ip 192.168.0.0 0.0.255.255 any
    dialer-list 1 protocol ip permit
    !
    line con 0
     exec-timeout 0 0
     modem enable
     stopbits 1
    line aux 0
     exec-timeout 0 0
     script dialer Dialout
     modem Dialin
     modem autoconfigure discovery
     transport input all
     stopbits 1
     speed 38400
     flowcontrol hardware
    line vty 0 4
     login local
    !
    scheduler max-task-time 5000
    end
    Configuring Dial Backup and Remote Management for Cisco 831 
    Router and Cisco SOHO 91 Router
    Figure 4-11 and Ta b l e 4 - 1 3 show how dial backup and remote management work 
    in a DSL modem environment when the primary line goes down. Note that the 
    cable modem environment is currently not supported. 
    						
    							 
    4-49
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    Figure 4-11 Cisco 831 Router Dial Backup and Remote Management in a DSL Modem Environment
    Follow the steps below to configure dial backup and remote management for the 
    Cisco 831 router. Callout 
    Number Description
    1Main WAN link; primary connection to Internet service provider
    2Dial backup; serves as a failover link when primary line goes down
    3Remote management; serves as a dial-in access to allow change or update of Cisco IOS 
    configurations
    82270
    2
    1
    3
    3
    2
    DSL
    831Ethernet
    DSL
    modem
    Modem Modem
    Modem
    PC3620
    PSTN
    Command Task
    Step 1ip name-server 206.13.28.12Enter your ISP DNS IP address.
    Step 2ip dhcp pool 1Configure CPE as a local DHCP server.
    Step 3vpdn enableEnable VPDN.
    Step 4vpdn-group 1Specify VPDN group for protocol PPPoE. 
    						
    							 
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    4-50
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Configuration Example for the Cisco 831 Router
    The following example configures dial backup and remote management on a 
    Cisco 831 router. 
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    Step 5chat-script Dialout ABORT ERROR 
    ABORT BUSY ““ “AT” OK “AT D T  
    5555102 T” TIMEOUT 45 CONNECT \c Configure a chap script for a modem.
    Step 6interface Async1Enter configuration mode for the async 
    interface.
    Step 7interface Dialer3Enter configuration mode for the dialer 
    interface.
    Step 8ip nat inside source list 101 interface 
    Dialer3 overloadEstablish the Ethernet interface as the inside 
    interface.
    Step 9ip route 0.0.0.0 0.0.0.0 ! (dial backup peer 
    address @ISP)Set the IP route to point to the dialer interface 
    as a default gateway.
    Step 10access-list 101 permit ip 192.168.0.0 
    0.0.255.255 anyDefine an extended access list permitting 
    addresses that need translation.
    Step 11dialer watch-list 1 ip ! (peer address @ISP) 
    255.255.255.255Evaluate the status of the primary link, based 
    on the existence of routes to the peer. 
    Step 12line con 0Enter configuration mode for the console 
    interface.
    Step 13modem enableChange the console port to the auxiliary port.
    Step 14line aux 0Enter configuration mode for the auxiliary 
    interface.
    Step 15flowcontrol hardwareEnable hardware signal flow control. Command Task 
    						
    							 
    4-51
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    memory-size iomem 20
    enable password cisco
    !
    ip subnet-zero
    ip name-server 206.13.28.12
    ip name-server 206.13.31.12
    ip name-server 63.203.35.55
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool 1
    import all
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    !
    ip audit notify log
    ip audit po max-events 100
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pppoe
    !
    ! Need to use your own correct ISP phone number
    modemcap entry MY-USER_MODEM:MSC=&F1S0=1
    chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102\T”
    TIMEOUT 45 CONNECT \c
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    hold-queue 100 out
    !
    interface Ethernet1
    no ip address
    no ip route-cache
    no ip mroute-cache
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    !Dial backup and remote management physical interface
    interface Async1
    no ip address
    encapsulation ppp
    dialer in-band 
    						
    							 
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    4-52
    Cisco 800 Series Software Configuration Guide
    78-5372-06 dialer pool-member 3
    async default routing
    async dynamic routing
    async mode dedicated
    ppp authentication pap callin
    !
    ! Primary wan link
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    dialer pool 1
    ppp authentication pap callin
    ppp pap sent-username account password 7 pass
    ppp ipcp dns request
    ppp ipcp wins request
    ppp ipcp mask request
    !
    ! Dialer backup logical interface
    interface Dialer3
    ip address negotiated
    ip nat outside
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    dialer pool 3
    dialer idle-timeout 60
    dialer string 5555102 modem-script Dialout
    dialer watch-group 1
    !
    ! Remote management PC ip address
    peer default ip address 192.168.2.2
    no cdp enable
    !
    ! Need to use your own ISP account and password
    ppp pap sent-username account password 7 pass
    ppp ipcp dns request
    ppp ipcp wins request
    ppp ipcp mask request
    !
    ! IP NAT over Dialer interface using route-map
    ip nat inside source route-map main interface Dialer1 overload
    ip nat inside source route-map secondary interface Dialer3 overload
    ip classless
    !
    ! When primary link is up again, distance 50 will override 80 if dial 
    backup hasn’t timeout 
    						
    All Cisco manuals Comments (0)