Home > Cisco > Router > Cisco Router 800 Series Software Configuration Guide

Cisco Router 800 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 800 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    Page
    of 600
    							 
    7-51
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring a Multiple-PVC Environment
    The tasks for configuring a voice and data network on the same subnet with virtual 
    circuit bundling are as follows:
    Configuring the ATM interface
    Configuring the PVC-bundle for voice
    Configuring the PVC-bundle for data
    Configuring IP Precedence for voice packets
    Configuring the ATM Interface, PVC-Bundle for Voice and Data, and IP 
    Precedence for Voice Packets
    Follow the steps below to configure the ATM interface, the PVC-bundle for voice 
    and data, and IP Precedence for the voice packets, beginning in global 
    configuration mode.
    Command Task
    Step 1interface ATM 0Enter configuration mode for the ATM 
    interface.
    Step 2dsl equipment-type co/cpeConfigure the DSL equipment type.
    Step 3dsl linerate number/autoSpecify the G.SHDSL line rate. The range of 
    valid numbers is between 72 and 2312.
    Step 4dsl operating-mode gshdsl symmetric 
    annex annexSet the G.SHDSL operating mode, and select 
    the G.991.2 annex.
    Step 5ip address ip-address maskSet the IP address and subnet mask for the 
    ATM interface.
    Step 6bundle nameSpecify a bundle name.
    Step 7encapsulation typeSpecify the encapsulation type for the voice 
    bundle PVC. 
    Step 8protocol ip ip-address broadcastSet the protocol broadcast for the IP address.
    Step 9pvc-bundle name vpi/vciCreate a PVC for the voice bundle.
    Step 10vbr-rt pcr scr bs  Set the service class for the voice bundle.1
    Step 11ip precedence numberSelect an IP Precedence level specific to the 
    voice bundle that you created. 
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring a Multiple-PVC Environment
    7-52
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Specifying IP Precedence and the Service Class for the Voice 
    Network
    Follow the steps below to configure real-time voice traffic precedence over other 
    IP network traffic, beginning in global configuration mode.
    NoteIn IP Precedence, the numbers 1 through 5 identify classes for IP flows; the 
    numbers 6 through 7 are used for network and backbone routing and updates. It is 
    recommended that IP Precedence 5 is used for voice packets.
    Step 12pvc-bundle name vpi/vciCreate a PVC for the data bundle.
    Step 13ubr pcrSet the service class for the data2 bundle.
    Step 14precedence otherSet the IP Precedence level other to the data 
    bundle that you created.
    Step 15exitExit configuration mode for the ATM 
    interface.
    1. For voice, the service class must be vbr-rt or vbr-nrt.
    2. For data, the service class must be vbr-nrt or ubr.
    Command Task
    Command Task
    Step 1dial-peer voice number voipEnter the dial peer configuration mode to 
    configure a VoIP dial peer.
    Step 2destination-pattern numberSet a destination pattern.
    Step 3session target {ipv4:destination-address} Specify a destination IP address for the dial 
    peer.
    Step 4precedence numberSelect a precedence level for the voice traffic 
    associated with that dial peer. 
    						
    							 
    7-53
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring Dial Backup
    Configuration Example
    The following configuration shows both voice and data on the same subnet with 
    virtual circuit bundling. IP precedence is set to 5 for the voice packets, but not for 
    the data packets so that the traffic can be separated onto two different ATM PVCs.
    !
    interface atm0
    ip address 20.0.0.1 255.0.0.0
    bundle test
    encapsulation aal5snap
    protocol ip 20.0.0.2 broadcast
    !
    pvc-bundle voice 1/100 
    vbr-rt 424 424 5
    precedence 5
    !
    pvc-bundle data 1/101
    precedence other
    !
    dial-peer voice 100 voip
    destination-pattern 26..
    session target ipv4:20.0.0.8
    ip precedence 5
    !
    Configuring Dial Backup
    You must decide whether to activate the backup interface when the primary line 
    goes down, when the traffic load on the primary line exceeds the defined 
    threshold, or when either occurs. The tasks you perform depend on your decision. 
    Perform the tasks in the following sections to configure dial backup:
    Specifying the Backup Interface (mandatory)
    Defining Backup Line Delays (optional)
    Defining Traffic Load Threshold (optional)
    Then configure the backup interface for DDR, so that calls are placed as needed.  
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring Dial Backup
    7-54
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Specifying the Backup Interface
    To specify a backup interface for a primary WAN interface or subinterface, enter 
    the backup interface type number command to select a backup interface.
    NoteWhen you use a BRI for a dial backup, neither of the B channels can be used while 
    the interface is in standby mode. In addition, when a BRI is used as a backup 
    interface and the BRI is configured for legacy DDR, only one B channel is usable. 
    Once the backup is initiated over one B channel, the second B channel is 
    unavailable. When the backup interface is configured for dialer profiles, both B 
    channels can be used.
    For more information regarding the available dial backup mechanisms in IOS, 
    please go to the following URL:
    http://www.cisco.com/warp/public/123/backup-main.html
    Defining Backup Line Delays
    You can configure a value that defines how much time should elapse before a 
    secondary line status changes after a primary line status has changed. You can 
    define two delays:
    A delay that applies after the primary line goes down but before the secondary 
    line is activated
    A delay that applies after the primary line comes up but before the secondary 
    line is deactivated
    To define these delays, use the following syntax:
    Router (config-if) # backup delay {enable-delay | never} {disable-delay | never} 
    						
    							 
    7-55
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring Dial Backup
    Defining Traffic Load Threshold
    You can configure dial backup to activate the secondary line, based on the traffic 
    load on the primary line. The software monitors the traffic load and computes a 
    5-minute moving average. If this average exceeds the value you set for the line, 
    the secondary line is activated and, depending on how the line is configured, some 
    or all of the traffic will flow onto the secondary dialup line.
    You can configure a load level for traffic at which additional connections will be 
    added to the primary WAN interface. The load level values range from 1 
    (unloaded) to 255 (fully loaded). 
    Use the following syntax to define a WAN line threshold:
    Router (config-if) # dialer load-threshold 8 outbound {enable-threshold | 
    never} {disable-threshold | never}
    Dial Backup Using the Console Port
    The following example shows dial backup using a console port configured for 
    DDR:
    interface atm 0
    ip address 172.30.3.4 255.255.255.0
    backup interface async1
    backup delay 10 10 
    !
    interface async 1
    ip address 172.30.3.5 255.255.255.0
    dialer in-band
    dialer string 5551212
    dialer-group 1
    async dynamic routing
    dialer list 1 protocol ip permit
    chat-script sillyman “““atdt 5551212” TIMEOUT 60 “CONNECT”
    line aux 0
    modem chat-script sillyman
    modem inout
    speed 9600 
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring Dial Backup
    7-56
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Configuration Example
    The following example shows configuration of dial backup and remote router 
    management on the Cisco 831 and Cisco 837 routers using the console port and 
    dialer watch.
    !
    username Router password !PASSWORD
    !
    modemcap entry MY_USR_MODEM:MSC=&F1S0=1
    !
    chat-script Dialout ABORT ERROR ABORT BUSY  AT OK ATDT 5555102\T 
    TIMEOUT 60 CONNECT \c
    !
    interface Async1
     no ip address
     encapsulation ppp
     dialer in-band
     dialer pool-member 3
     autodetect encapsulation ppp
     async default routing
     async dynamic routing
     async mode dedicated
     pap authentication pap callin
    !
    ! Dialer3 is for dial backup and remote router management
    !
    interface Dialer3
     ip address negotiated
     encapsulation ppp
     no ip route-cache
     no ip mroute-cache
     dialer pool 3
     dialer remote-name !REMOTE-NAME
     dialer idle-timeout 300
     dialer string 5555102 modem-script Dialout
     dialer watch-group 1
     dialer-group 1
     autodetect encapsulation ppp
     peer default ip address 192.168.2.2
     no cdp enable
     ppp pap sent-username ! USER SPECIFIC password ! USER SPECIFIC
     ppp ipcp dns request
     ppp ipcp wins request
     ppp ipcp mask request
    !
    ! IP NAT over Dialer interface using route-map 
    						
    							 
    7-57
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring Dial Backup
    ip nat inside source route-map main interface Dialer1 overload
    ip nat inside source route-map secondary interface Dialer3 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 !(dial backup peer address @ISP)
    ip route 0.0.0.0 0.0.0.0 Dialer1 150
    !
    no ip http server
    ip pim bidir-enable
    !
    !
    access-list 101 permit ip 192.168.0.0 0.0.255.255 any
    dialer watch-list 1 ip !(ATM peer address @ISP) 255.255.255.255
    dialer-list 1 protocol ip permit
    !
    ! To direct traffic to an interface only if the Dialer gets assigned 
    with an ip address
    route-map main permit 10
    match ip address 101
    match interface Dialer1
    !
    route-map secondary permit 10
    match ip address 101
    match interface Dialer3
    !
    line con 0
     exec-timeout 0 0
     modem enable
     stopbits 1
    line aux 0
     exec-timeout 0 0
     script dialer Dialout
     modem InOut
     modem autoconfigure type MY_USR_MODEM
     transport input all
     stopbits 1
     speed 38400
     flowcontrol hardware
    line vty 0 4
     exec-timeout 0 0
     login local
    !
    The following example shows configuration of remote management using a 
    console port for the Cisco SOHO 91 and Cisco SOHO 97 routers.
    !
    username Router password !PASSWORD
    ! 
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring Dial Backup
    7-58
    Cisco 800 Series Software Configuration Guide
    78-5372-06 modemcap entry MY_USR_MODEM:MSC=&F1S0=1
    !
    interface Async1
    no ip address
    encapsulation ppp
    dialer in-band
    autodetect encapsulation ppp
    async default routing
    async dynamic routing
    async mode dedicated
    pap authentication pap callin
    peer default ip address pool clientpool
    !
    ! dialer 1 used for PPPoE or PPPoATM
    ! PPPoE or PPPoATM dialer1 configurations are not shown in this sample
    !
    ip route 0.0.0.0 0.0.0.0 dialer 1 150
    !
    dialer list 1 protocol ip permit
    !
    ip local pool clientpool 192.168.0.2 192.168.0.10
    !
    line con 0
    exec-timeout 0 0
    modem enable
    stopbits 1
    line aux 0
    exec-timeout 0 0
    modem Dialin
    modem autoconfigure type MY_USER_MODEM
    transport input all
    stopbits 1
    speed 38400
    flowcontrol hardware
    to align with line aux 0
    exec-timeout 0 0
    login local
    !
    Configuration Example
    The following example shows dial backup and remote management configuration 
    on the Cisco 836 router, using the ISDN S/T port and dialer watch.
    Cisco836#
    ! 
    						
    							 
    7-59
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring Dial Backup
    vpdn enable
    !
    vpdn-group 1
    accept-dialin
    protocol pppoe
    !
    !Specifies the ISDN switch type
    isdn switch-type basic-net3
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    hold-queue 100 out
    !
    !ISDN interface to be used as a backup interface
    interface BRI0
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-net3
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 1/40
    encapsulation aal5snap
    pppoe-client dial-pool-number 2
    !
    dsl operating-mode auto
    !
    ! Dial backup interface, associated with physical BRI0 interface. 
    Dialer pool 1 associates it with BRI0’s dialer pool member 1. Note 
    “dialer watch-group 1” associates a watch list with corresponding 
    “dialer watch-list” command
    interface Dialer0
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 30
    dialer string 384040
    dialer watch-group 1
    dialer-group 1
    !
    ! Primary interface associated with physical ATM0 interface, dialer 
    pool 2 associates it with ATM0’s dial-pool-number2
    interface Dialer2
    ip address negotiated
    ip mtu 1492
    encapsulation ppp 
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring IGMP Proxy and Sparse Mode
    7-60
    Cisco 800 Series Software Configuration Guide
    78-5372-06 dialer pool 2
    dialer-group 2
    no cdp enable
    !
    ip classless
    !Primary and backup interface given route metric
    ip route 0.0.0.0 0.0.0.0 22.0.0.2
    ip route 0.0.0.0 0.0.0.0 192.168.2.2 80
    ip http server
    !
    !Watch for interesting traffic
    dialer watch-list 1 ip 22.0.0.2 255.255.255.255
    !Specifies interesting traffic to trigger backup ISDN traffic
    dialer-list 1 protocol ip permit
    !
    Configuring IGMP Proxy and Sparse Mode
    The Internet Group Management Protocol (IGMP) proxy feature was added to the 
    unidirectional link routing feature to permit hosts that are not directly connected 
    to a downstream router to join a multicast group sourced from an upstream 
    network.
    Follow the steps below to configure IGMP proxy and sparse mode, starting in 
    global configuration mode. 
    Command Task
    Step 1ip multicast-routingEnable IP multicast forwarding.
    Step 2ip pim rp-address addressConfigure the Protocol Independent Multicast 
    (PIM) Rendezvous Point (RP) address.
    Step 3interface ethernet 0Enter Ethernet 0 interface configuration 
    mode.
    Step 4ip address ip-address subnet-maskConfigure an IP address and subnet mask for 
    the Ethernet 0 interface.
    Step 5ip pim { sparse |dense }-modeConfigure the Ethernet 0 interface for PIM 
    sparse mode or PIM dense mode.
    Step 6interface Ethernet 1Enter Ethernet 1 configuration mode. 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 800 Series Software Configuration Guide