Home > Cisco > Router > Cisco Router 800 Series Software Configuration Guide

Cisco Router 800 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 800 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    Page
    of 600
    							 
    8-5
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 8      Advanced Router Configuration
    Configuring TCP Maximum Segment Size for PPPoE
    Configuring TCP Maximum Segment Size for PPPoE
    The configuring TCP maximum segment size for PPP over Ethernet feature is 
    supported on the following Cisco routers:
    Cisco 806 and 831
    Cisco 826 and 836
    Cisco 827, 827H, 827-4V, and 837
    Cisco SOHO 77, SOHO 77H, SOHO 78, SOHO 96, and SOHO 97
    Cisco 828
    If a Cisco router terminates the PPPoE traffic, a computer connected to the 
    Ethernet interface may have problems accessing websites. The solution is to 
    manually reduce the maximum transmission unit (MTU) configured on the 
    computer by constraining the TCP maximum segment size (MSS). Enter the 
    following command on the router’s Ethernet 0 interface:
    ip tcp adjust-mss mss
    where mss is 1452 or less.
    Configuration Example
    The following example shows a configuration of a PPPoE client.
    vpdn enable
    no vpdn logging
    !
    vpdn-group 1
     request-dialin
      protocol pppoe
    !
    interface Ethernet0
     ip address 192.168.100.1 255.255.255.0
     ip tcp adjust-mss 1452
     ip nat inside
    !
    interface ATM0
     no ip address
     no atm ilmi-keepalive
     pvc 8/35 
      pppoe-client dial-pool-number 1 
    						
    							 
    Chapter 8      Advanced Router Configuration
    Configuring Low Latency Queuing and Link Fragmentation and Interleaving
    8-6
    Cisco 800 Series Software Configuration Guide
    78-5372-06 !
    dsl operating-mode auto
    !
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username sohodyn password 7 141B1309000528
    !
    ip nat inside source list 101 interface Dialer1 overload
    ip route 0.0.0.0.0.0.0.0 Dialer1
    access-list 101 permit ip 192.168.100.0.0.0.0.255 any
    Configuring Low Latency Queuing and Link 
    Fragmentation and Interleaving
    Low latency queuing (LLQ) provides a low-latency, strict-priority transmit queue 
    for voice over IP (VoIP) traffic. 
    LLQ is supported on the following Cisco routers:
    Cisco 806
    Cisco 826 and 836
    Cisco 827, 827H, 827-4V, 831, and 837
    Cisco 828
    Link fragmentation and interleaving (LFI) reduces voice traffic delay and jitter by 
    fragmenting large data packets and interleaving voice packets within the data 
    fragments.  
    						
    							 
    8-7
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 8      Advanced Router Configuration
    Configuring Low Latency Queuing and Link Fragmentation and Interleaving
    Configuring Low Latency Queuing
    Follow the steps below to configure the router for LLQ :
    Step 1Ensure that the voice and data packets have different IP precedence values so 
    that the router can differentiate between them. Normally, data packets should 
    have an IP precedence of 0, and voice packets should have an IP precedence of 5. 
    If the VoIP packets are generated from within the router, you may set the IP 
    precedence to 5 for these packets by entering the ip precedence number 
    command in dial-peer voice configuration mode as follows:
    a.Enter the global configuration dial-peer voice 1 voip command.
    b.Enter the ip precedence 5 command.
    Step 2Create an access list and a class map for the voice packets.
    a.Create an access list by entering the access-list 101 permit ip any any 
    precedence 5 command.
    b.Create a class map for the voice packets by entering class-map match-all 
    voice command.
    c.Link the class map to the access list by entering the match access-group 101 
    command.
    Step 3Create LLQ for voice traffic.
    a.Create a policy map by entering the policy-map mypolicy command.
    b.Define the class by entering the class voice command.
    c.Assign the priority bandwidth to the voice traffic. The priority bandwidth 
    assigned to the voice traffic depends on the codec used and the number of 
    simultaneous calls that you allow. For example, a G.711 codec call consumes 
    200 kbps; therefore, to support one G.711 voice call you would enter a 
    priority 200 command.
    Step 4Attach LLQ to the dialer interface.
    a.Enter the global configuration interface dialer 1 command.
    b.Create a service policy by entering the service-policy out mypolicy 
    command. 
    						
    							 
    Chapter 8      Advanced Router Configuration
    Configuring LFI
    8-8
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Configuring LFI
    Follow the steps below to configure the router for LFI.
    NoteWhen you are configuring LFI, the data fragment size must be greater than the 
    voice packet size; otherwise, the voice packets fragment, and voice quality 
    deteriorates.
    Step 1Configure the dialer bandwidth. The dialer interface has a default bandwidth of 
    56 kbps, which may be less than the upstream bandwidth of your digital 
    subscriber line (DSL) connection. You can find the upstream bandwidth of your 
    DSL connection by entering the show dsl interface atm0 command in dialer 
    interface configuration mode. If you have two or more PVCs sharing the same 
    DSL connection, the bandwidth configured for the dialer interface must be the 
    same as the bandwidth allocated to its assigned PVC.
    Step 2Enable PPP multilink, and configure fragment delay and interleaving for the 
    dialer interface. 
    a.Enter the global configuration interface dialer 1 command.
    b.Specify the dialer bandwidth by entering the bandwidth 640 command. The 
    bandwidth is specified in kilobits per second (kbps).
    c.Enter the ppp multilink command.
    d.Specify PPP multilink interleaving by entering the ppp multilink interleave 
    command.
    e.Define the fragment delay by entering the ppp multilink fragment-delay 10 
    command.
    f.Calculate the fragment size using the following formula:
    fragment size = (bandwidth in kbps/ 8) * fragment-delay in milliseconds (ms)
    In this case, the fragment size = (640/8) * 10, resulting in a fragment size of 
    800. The fragment size is greater than the maximum voice packet size of 200, 
    which is G.711 20 ms. A low fragment delay corresponds to a fragment size 
    that may be smaller than the voice packet size, resulting in reduced voice 
    quality. 
    						
    							 
    8-9
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 8      Advanced Router Configuration
    Configuring Class-Based Traffic Shaping to Support Low Latency Queuing
    Configuring Class-Based Traffic Shaping to Support 
    Low Latency Queuing
    Class-based traffic shaping (CBTS) is supported on the following Cisco routers:
    Cisco 806 
    Cisco 831 
    CBTS can be used to control the WAN interface traffic transmission speed to 
    match the speed of the attached broadband modem or of the remote target 
    interface. CBTS ensures that the traffic conforms to the policies configured for it, 
    thereby eliminating topology bottlenecks with data-rate mismatches. 
    The shape average kbps and the shape peak kbps commands enable you to define 
    traffic shaping for an interface.
    NoteCBTS is supported on the Ethernet 1 interface.
    Configuring CBTS for LLQ
    Follow the steps below to configure CBTS, beginning in global configuration 
    mode. This procedure shows how to create multiple traffic classes and associate 
    them with policy maps, and then to associate the policy maps with a router 
    interface. 
    Step 1Define a traffic classification.
    a.Enter the class-map map-name command to define a traffic classification. 
    For example, the name voice could be used to specify that this is a class map 
    for voice traffic.
    b.Now in class configuration mode, enter the match ip precedence 5 command 
    to match all IP voice traffic with a precedence of 5. Cisco Architecture for 
    Voice, Video and Integrated Data (AVVID) documentation specifies a 
    precedence value of 5 for voice-over-IP traffic.
    c.Enter exit to leave class configuration mode. 
    						
    							 
    Chapter 8      Advanced Router Configuration
    Configuring Class-Based Traffic Shaping to Support Low Latency Queuing
    8-10
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Step 2Define a policy map and associated classes for low-latency queuing.
    a.Enter the policy-map map-name command in global configuration mode to 
    construct policies and to allocate different network resources for the defined 
    traffic classes. The name LLQ could be used to specify that this is the policy 
    map for LLQ.
    b.Now in policy-map mode, define a class to handle voice traffic by entering 
    class QOS-class-name, using the class-map name you defined using the 
    class-map command in Step 1. This command places the router in QOS-class 
    configuration mode.
    c.Enter priority number, where number is bandwidth in kilobits per second. A 
    value of 300, as shown in the example configuration, provides enough 
    bandwidth for two G.711 voice ports. Before setting a priority value, refer to 
    the specification for the CODEC used for voice calls.
    d.Enter exit to return to policy-map configuration mode.
    e.Enter class class-default to use the default class for all traffic other than 
    voice traffic. The name class-default is well known, and does not have to be 
    predefined using the class-map command.
    f.Apply WFQ to non-voice traffic by entering the fair-queue command.
    g.Enter exit twice to return to global configuration mode.
    Step 3Define a traffic-shaping policy map.
    a.Enter policy-map map-name in global configuration mode. The name shape 
    should be used to indicate this map defines overall traffic shaping that is 
    compatible with the remote transmission rate bandwidth.
    b.Enter class class-default to associate the default class with this policy map. 
    c.Set the transmission speed to be used after traffic shaping to match the speed 
    of the broadband modem or remote interface by entering the shape average 
    kbps command, where kbps is a value in kilobits per second.
    CautionThe transmission speed entered must be less than or equal to the TX 
    bandwidth of the DSL or cable modem to which the router is attached. 
    Specifying a value greater than the modem’s TX bandwidth will result 
    in the modem’s becoming congested, and the benefits of applying QOS 
    might be lost. 
    						
    							 
    8-11
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 8      Advanced Router Configuration
    Configuring Class-Based Traffic Shaping to Support Low Latency Queuing
    d.Enter service-policy name to associate the LLQ policy map with the 
    traffic-shaping policy map. If the map name for the low-latency queue were 
    LLQ, then name would be LLQ.
    e.Enter exit twice to return to global configuration mode.
    Step 4Apply these policies to the Ethernet 1 interface.
    a.Enter the interface Ethernet 1 command.
    b.Apply the service policy to the Ethernet 1 interface by entering 
    service-policy output
     name, where name matches the policy defined in the 
    traffic-shaping policy map. If the traffic-shaping policy map name were 
    shape, the service-policy name would also be shape. 
    Step 5Enter end to leave router configuration mode.
    Configuration Example
    The following example shows how a Cisco 806 router can be configured to 
    connect to a broadband modem with limited bandwidth, while ensuring voice line 
    quality. Two policy maps are configured: 
    Policy map LLQ
    Policy map shape
    Policy map LLQ ensures that voice traffic has a strict priority queue with 
    bandwidth of up to 300 kbps. The policy map shape limits the total throughput to 
    2.2 MBps.
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password encryption
    !
    hostname 806-uut
    !
    ip subnet-zero
    !
    class-map match-all voice
     match ip precedence 5
    !
    ! 
    						
    							 
    Chapter 8      Advanced Router Configuration
    Configuring the Length of the PVC Transmit Ring
    8-12
    Cisco 800 Series Software Configuration Guide
    78-5372-06 policy-map LLQ
      class voice
        priority 300
      class class-default
       fair-queue
    policy-map shape
      class class-default
       shape average 2250000
       service-policy LLQ
    !
    interface Ethernet0
     ip address 1.7.65.11 255.255.0.0
    !
    interface Ethernet1
     ip address 192.168.1.101 255.255.255.0
    service-policy output shape
    !
    ip classless
    ip http server
    ip pim bidir-enable
    !
    line con 0
     stopbits 1
    line vty 0 4
     login
    !
    !
    scheduler max-task-time 5000
    end
    !
    Configuring the Length of the PVC Transmit Ring
    The length of the PVC transmit ring can be configured on the following Cisco 
    routers:
    Cisco 826 and 836
    Cisco 827, 827H, 827-4V, and 837
    Cisco SOHO 77, SOHO 77H, SOHO 78, SOHO 96, and SOHO 97
    Cisco 828  
    						
    							 
    8-13
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 8      Advanced Router Configuration
    Configuring the Length of the PVC Transmit Ring
    If both voice and data packets share the same PVC, it is important to reduce the 
    PVC transmit (TX) ring size. This reduces the maximum number of data packets 
    and fragments that can be in front of a voice packet in the hardware queue, thus 
    reducing latency.
    Follow these steps to reduce the PVC TX ring size:
    Step 1Enter the global configuration int atm 0 command.
    Step 2Specify the PVC number by entering the pvc 1/100 command.
    Step 3Reduce the PVC TX ring size to 3 by entering the tx-ring-limit 3 command.
    Configuration Example
    The following example combines LFI, LLQ, and the PVC TX ring configurations.
    class-map match-all voice
    match access-group 101
    !
    policy-map mypolicy
     class voice
      priority 200 
     class class-default
      fair-queue
    !
    interface Ethernet0
    ip address 70.0.0.1 255.255.255.0
    no ip mroute-cache
    !
    interface ATM0
     no ip address
     bundle-enable
     dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
     no ip mroute-cache
     pvc 1/40 
     encapsulation aal5mux ppp dialer
     dialer pool-member 1
     tx-ring-limit 3
    !
    interface Dialer1
     bandwidth 640 
    						
    							 
    Chapter 8      Advanced Router Configuration
    Configuring DHCP Server Import
    8-14
    Cisco 800 Series Software Configuration Guide
    78-5372-06  ip address 60.0.0.1 255.255.255.0
     encapsulation ppp
     dialer pool 1
     service-policy output mypolicy
     ppp multilink
     ppp multilink fragment-delay 10
     ppp multilink interleave
    !
    ip classless
    no ip http server
    !
    access-list 101 permit ip any any precedence 5
    !
    voice-port 1
    !
    voice-port 2
    !
    voice-port 3
    !
    voice-port 4
    dial-peer voice 110 pots
     destination-pattern 1105555
     port 1
    !
    dial-peer voice 210 voip
     destination-pattern 2105555
     session target ipv4:60.0.0.2
     codec g711ulaw
     ip precedence 5
    Configuring DHCP Server Import
    The Cisco IOS DHCP server has been enhanced to allow configuration 
    information to be updated automatically by PPP. You can enable PPP to 
    automatically configure the Domain Name System (DNS), the Windows 
    Information Name Server (WINS), or the NetBIOS Name Service (NBNS), and 
    the server IP address information within a Cisco IOS DHCP server pool.
    This feature is supported on the following Cisco routers:
    Cisco 806 and 831
    Cisco 826 and 836
    Cisco 827, 827H, 827-4V, and 837 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 800 Series Software Configuration Guide