Home > Cisco > Router > Cisco Router 800 Series Software Configuration Guide

Cisco Router 800 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 800 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    Page
    of 600
    							 
    4-33
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    Configuration Example
    The following configuration example for a Cisco 837 router specifies an IP 
    address for the ATM interface via PPP/IPCP address negotiation and dial backup 
    over the console port.
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    memory-size iomem 20
    enable password cisco
    !
    ip subnet-zero
    ip name-server 206.13.28.12
    ip name-server 206.13.31.12
    ip name-server 63.203.35.55
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool 1
    import all
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    !
    ip audit notify log
    ip audit po max-events 100
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pppoe
    !
    ! Need to use your own correct ISP phone number
    modemcap entry MY-USER_MODEM:MSC=&F1S0=1
    chat-script Dialout ABORT ERROR ABORT BUSY ““ “AT” OK “ATDT 5555102\T”
    TIMEOUT 45 CONNECT \c
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside 
    						
    							 
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    4-34
    Cisco 800 Series Software Configuration Guide
    78-5372-06 ip tcp adjust-mss 1452
    hold-queue 100 out
    !
    interface ATM0
    mtu 1492
    no ip address
    no atm ilmi-keepalive
    pvc 0/35
    pppoe-client dial-pool-number 1
    !
    dsl operating-mode auto
    !
    !Dial backup and remote management physical interface
    interface Async1
    no ip address
    encapsulation ppp
    dialer in-band
    dialer pool-member 3
    async default routing
    async dynamic routing
    async mode dedicated
    ppp authentication pap callin
    !
    ! Primary wan link
    interface Dialer1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    ppp authentication pap callin
    ppp pap sent-username account password 7 pass
    ppp ipcp dns request
    ppp ipcp wins request
    ppp ipcp mask request
    !
    ! Dialer backup logical interface
    interface Dialer3
    ip address negotiated
    ip nat outside
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    dialer pool 3
    dialer idle-timeout 60
    dialer string 5555102 modem-script Dialout
    dialer watch-group 1
    !
    ! Remote management PC ip address 
    						
    							 
    4-35
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    peer default ip address 192.168.2.2
    no cdp enable
    !
    ! Need to use your own ISP account and password
    ppp pap sent-username account password 7 pass
    ppp ipcp dns request
    ppp ipcp wins request
    ppp ipcp mask request
    !
    ! IP NAT over Dialer interface using route-map
    ip nat inside source route-map main interface Dialer1 overload
    ip nat inside source route-map secondary interface Dialer3 overload
    ip classless
    !
    ! When primary link is up again, distance 50 will override 80 if dial 
    backup hasn’t timeout
    ! Multiple routes because peer ip addresses are alternated among them 
    when CPE gets connected
    ip route 0.0.0.0 0.0.0.0 64.161.31.254 50
    ip route 0.0.0.0 0.0.0.0 66.125.91.254 50
    ip route 0.0.0.0 0.0.0.0 64.174.91.254 50
    ip route 0.0.0.0 0.0.0.0 63.203.35.136 80
    ip route 0.0.0.0 0.0.0.0 63.203.35.137 80
    ip route 0.0.0.0 0.0.0.0 63.203.35.138 80
    ip route 0.0.0.0 0.0.0.0 63.203.35.139 80
    ip route 0.0.0.0 0.0.0.0 63.203.35.140 80
    ip route 0.0.0.0 0.0.0.0 63.203.35.141 80
    ip route 0.0.0.0 0.0.0.0 Dialer1 150
    no ip http server
    ip pim bidir-enable
    !
    ! PC ip address behind CPE
    access-list 101 permit ip 192.168.0.0 0.0.255.255 any
    access-list 103 permit ip 192.168.0.0 0.0.255.255 any
    !
    ! Watch multiple ip address because peers are alternated among them 
    when CPE gets connected
    dialer watch-list 1 ip 64.161.31.254 255.255.255.255
    dialer watch-list 1 ip 64.174.91.254 255.255.255.255
    dialer watch-list 1 ip 64.125.91.254 255.255.255.255
    !
    ! Dial backup will kick in if primary link is not available 5 minutes 
    after CPE starts up
    dialer watch-list 1 delay route-check initial 300
    dialer-list 1 protocol ip permit
    !
    ! To direct traffic to an interface only if the Dialer gets assigned 
    with an ip address 
    						
    							 
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    4-36
    Cisco 800 Series Software Configuration Guide
    78-5372-06 route-map main permit 10
    match ip address 101
    match interface Dialer1
    !
    route-map secondary permit 10
    match ip address 103
    match interface Dialer3
    !
    !
    line con 0
    exec-timeout 0 0
    !
    ! Change console to aux function
    modem enable
    stopbits 1
    line aux 0
    exec-timeout 0 0
    !
    ! To enable and communicate with the external modem properly
    script dialer Dialout
    modem InOut
    modem autoconfigure discovery
    transport input all 
    stopbits 1
    speed 115200
    flowcontrol hardware
    line vty 0 4
    exec-timeout 0 0
    password cisco
    login
    !
    scheduler max-task-time 5000
    end
    Configuring Dial Backup and Remote Management for the 
    Cisco 836 Router
    Follow the steps given in the “Configuring the Cisco 836 Router’s ISDN Settings” 
    section on page 4-37 to configure dial backup and remote management on the 
    Cisco 836 router’s ISDN S/T port.  
    						
    							 
    4-37
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    Configuring the Cisco 836 Router’s ISDN Settings
    The user must first configure the Cisco 836 router ISDN settings to configure the 
    router interface as a backup interface. Follow the steps below to configure the 
    Cisco 836 router ISDN interface as a backup interface, beginning in global 
    configuration mode. 
    NoteTraffic of interest must be present to activate the backup ISDN line by means of 
    the backup interface and floating static routes methods. Traffic of interest is not 
    needed for the dialer watch to activate the backup ISDN line.
    Command Task
    Step 1isdn switch-type basic-net3Specify the ISDN switch type.
    Step 2interface BRI0Enter configuration mode for the ISDN Basic 
    Rate Interface (BRI). 
    Step 3encapsulation pppSet BRI0 interface encapsulation type to PPP.
    Step 4dialer pool-member 1Specify the dialer pool membership.
    Step 5isdn switch-type basic-net3Specify the ISDN switch type.
    Step 6exitExit to return to global configuration mode.
    Step 7interface Dialer0Enter configuration mode for the dialer 
    interface.
    Step 8ip address negotiatedObtain the IP address from the peer.
    Step 9encapsulation pppSpecify Dialer 0 encapsulation type as PPP.
    Step 10dialer pool 1Specify the dialer pool to be used. Dialer pool 
    1 setting associates Dialer 0 interface with 
    BRI0 because the BRI0 dialer pool-member 
    value is “1.”
    Step 11dialer string 384040Specify the telephone number to be dialed.
    Step 12dialer-group 1Assign this interface to a dialer group. 
    						
    							 
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    4-38
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Configuring Dial Backup and Remote Management Settings
    As described in the “Dial Backup Feature Limitations and Configuration” section 
    on page 4-25, backup interface, static routes, and dialer watch are the three 
    methods used for implementing dial backup and remote management. This 
    section provides detailed procedures for configuring these three methods. 
    Configuring Backup Interface
    Follow the steps below to configure the Cisco 836 router ISDN interface as a 
    backup interface, beginning in global configuration mode. 
    Configuring Floating Static Route
    Static route and dynamic route are the two components of floating static routes. 
    Complete the following steps to configure the static route on the Cisco 836 router 
    ISDN port, beginning in global configuration mode. 
    Step 13exitExit to return to global configuration mode.
    Step 14dialer-list 1 portocol ip permitCreate a dialer list for packets of interest to be 
    forwarded through the specified interface 
    dialer group. Dialer-list 1 corresponds to 
    dialer-group 1. Command Task
    Command Task
    Step 1interface ATM0Enter ATM interface configuration mode.
    Step 2backup interface BRI0Assign BRI0 as the secondary backup 
    interface. 
    						
    							 
    4-39
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    NoteWhen the static routes are configured, the primary interface protocol must go 
    down in order to activate the floating static route.
    Follow the steps below to configure the dynamic route on the Cisco 836 router 
    ISDN port, beginning in global configuration mode.
    NoteThe floating static route depends on the routing protocol convergence times when 
    dynamic routing is activated.
    Configuring Dialer Watch
    Use the following steps to configure the dialer watch on the Cisco 836 router’s 
    ISDN port, beginning in global configuration mode. Command Task
    Step 1ip route 0.0.0.0 0.0.0.0 22.0.0.2Assign the primary route.
    Step 2ip route 0.0.0.0 0.0.0.0 192.168.2.2 150Assign the lower routing administrative 
    distance value for the backup interface route. 
    192.168.2.2 is the peer IP address of the 
    backup interface.
    Command Task
    Step 1router ripEnables RIP routing.
    Step 2network 22.0.0.0Define the primary interface network. 
    22.0.0.0 is the network value of the primary 
    interface.
    Step 3ip route 0.0.0.0 0.0.0.0 192.168.2.2 150Assign the lower routing administrative 
    distance value for the backup interface route. 
    192.168.2.2 is the peer IP address of the 
    backup interface. 
    						
    							 
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    4-40
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Configuration Example
    The next three configuration examples shows sample configurations for the three 
    dial backup interface and remote management methods. 
    The following is an example of configuring dial backup and remote management 
    using the backup interface command.
    Cisco836#
    !
    vpdn enable
    !
    vpdn-group 1
    accept-dialin
    protocol pppoe
    !
    !Specifies the ISDN switch type
    isdn switch-type basic-net3
    !
    interface Ethernet0
    Command Task
    Step 1interface Dialer0Enter configuration mode for the dial backup 
    interface.
    Step 2dialer watch-group 1Specify the group number for the watch list.
    Step 3exitExit to return to global configuration mode.
    Step 4ip route 0.0.0.0 0.0.0.0 22.0.0.2Assign the primary route. 22.0.0.2 is the peer 
    IP address of the primary interface.
    Step 5ip route 0.0.0.0 0.0.0.0 192.168.2.2 150Assign the lower routing administrative 
    distance value for the backup interface route. 
    192.168.2.2 is the peer IP address of the 
    backup interface.
    Step 6dialer watch-list 1 ip 22.0.0.2 
    255.255.255.255Assign an IP address to the watch list via the 
    dialer watch command. If the connection on 
    the primary interface is lost and the IP address 
    is unavailable on the Cisco 836 router, the 
    dial-out feature on the backup interface is 
    triggered. 22.0.0.2 is the peer IP address of 
    the primary interface. 
    						
    							 
    4-41
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    ip address 192.168.1.1 255.255.255.0
    hold-queue 100 out
    !
    !ISDN interface to be used as a backup interface
    interface BRI0
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-net3
    !
    interface ATM0
    backup interface BRI0
    no ip address
    no atm ilmi-keepalive
    pvc 1/40
    encapsulation aal5snap
    pppoe-client dial-pool-number 2
    !
    dsl operating-mode auto
    !
    ! Dial backup interface, associated with physical BRI0 interface. 
    Dialer pool 1 associates it with BRI0’s dialer pool member 1
    interface Dialer0
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 30
    dialer string 384040
    dialer-group 1
    !
    ! Primary interface associated with physical ATM0’s interface, dialer 
    pool 2 associates it with ATM0’s dial-pool-number2
    interface Dialer2
    ip address negotiated
    ip mtu 1492
    encapsulation ppp
    dialer pool 2
    dialer-group 2
    no cdp enable
    !
    ip classless
    !Primary and backup interface given route metric
    ip route 0.0.0.0 0.0.0.0 22.0.0.2
    ip route 0.0.0.0 0.0.0.0 192.168.2.2 80
    ip http server
    !
    !Specifies interesting traffic to trigger backup ISDN traffic
    dialer-list 1 protocol ip permit 
    						
    							 
    Chapter 4      Network Scenarios
    Configuring Dial Backup over the ISDN Interface
    4-42
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    The following is an example of configuring dial backup and remote management 
    using floating static routes.
    Cisco836#
    !
    vpdn enable
    !
    vpdn-group 1
    accept-dialin
    protocol pppoe
    !
    !Specifies the ISDN switch type
    isdn switch-type basic-net3
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    hold-queue 100 out
    !
    !ISDN interface to be used as a backup interface
    interface BRI0
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-net3
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 1/40
    encapsulation aal5snap
    pppoe-client dial-pool-number 2
    !
    dsl operating-mode auto
    !
    ! Dial backup interface, associated with physical BRI0 interface. 
    Dialer pool 1 associates it with BRI0’s dialer pool member 1
    interface Dialer0
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 30
    dialer string 384040
    dialer-group 1
    !
    ! Primary interface associated with physical ATM0’s interface, dialer 
    pool 2 associates it with ATM0’s dial-pool-number2
    interface Dialer2 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 800 Series Software Configuration Guide