Home > Cisco > Router > Cisco Router 800 Series Software Configuration Guide

Cisco Router 800 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 800 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    Page
    of 600
    							 
    4-83
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Voice Scenario
    Configure the data network by following the procedures in these sections:
    Configuring the Class Map, Route Map, and Policy Map 
    Configuring the Ethernet Interface
    Configuring the ATM Interface
    Configuring Enhanced IGRP
    Then, configure the voice network by following the procedures in these sections:
    Configuring the POTS Dial Peers
    Configuring VoIP Dial Peers for H.323 Signaling 
    For configuration examples, see the “Configuring the Class Map, Route Map, and 
    Policy Map” section on page 4-83, the “Configuring the Ethernet Interface” 
    section on page 4-84, the “Configuring the ATM Interface” section on page 4-84, 
    the “Configuring EIGRP” section on page 4-85, the “Configuring the POTS Dial 
    Peers” section on page 4-86, and the “Configuring VoIP Dial Peers for H.323 
    Signaling” section on page 4-86 provided in the sections below.
    Configuration examples are shown for the Cisco 827-4V router and the gateway 
    and gatekeeper endpoint routers. 
    After configuring your router, you need to configure the PVC endpoint. For a 
    general configuration example, see the “Cisco 3640 Gateway Configuration 
    Example” section on page 74.
    Configuring the Class Map, Route Map, and Policy Map
    Follow these steps to configure the class map, route map, and policy map, 
    beginning in global configuration mode.
    Command Task
    Step 1access-lists 101 permit ip any any 
    precedence 5Configure the access list.
    Step 2class-map voiceConfigure the class map.
    Step 3match access-group 101Assign access list 101 to the class map.
    Step 4route-map data permit 10Configure the route map.
    Step 5ip precedence routineSet the IP precedence. 
    						
    							 
    Chapter 4      Network Scenarios
    Voice Scenario
    4-84
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Configuring the Ethernet Interface
    Follow the steps below to configure the Ethernet interface, beginning in global 
    configuration mode.
    Configuring the ATM Interface
    Complete the following steps to configure the ATM interface, beginning in global 
    configuration mode.
    Step 6policy-map mypolicyConfigure a policy map.
    Step 7class voiceSpecify the class for queuing voice traffic.
    Step 8priority 176Specify the bandwidth for queuing.1
    Step 9class class-defaultConfigure the default class for all traffic but 
    voice traffic.
    1. Total bandwidth for the policy map may not exceed 75 percent of the total PVC bandwidth.
    Command Task
    Command Task
    Step 1interface ethernet 0Enter configuration mode for the Ethernet 
    interface.
    Step 2ip address 20.20.20.20 255.255.255.0Set the IP address and subnet mask for the 
    Ethernet interface.
    Step 3ip policy route-map data Configure the IP policy route map.
    Step 4ip route-cache policy Enable fast-switching policy routing.
    Step 5no shutdownEnable the Ethernet interface.
    Step 6exitExit configuration mode for the Ethernet 
    interface. 
    						
    							 
    4-85
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Voice Scenario
    Configuring EIGRP
    Follow the steps below to configure EIGRP, beginning in global configuration 
    mode. Command Task
    Step 1interface ATM 0Enter configuration mode for the ATM 
    interface.
    Step 2ip address 10.10.10.20 255.255.255.0Set the IP address and subnet mask for the 
    ATM interface.
    Step 3pvc 8/35Create an ATM PVC for each end node with 
    which the router communicates.
    Step 4encapsulation aal5snapSpecify the encapsulation type for the PVC.
    Step 5protocol ip 10.10.10.36 broadcastSpecify the protocol broadcast for the IP 
    address.
    Step 6service-policy output mypolicySpecify the service policy for the ATM 
    interface.
    Step 7vbr-nrt 640 640 1Specify the ATM service class.
    Step 8no shutdownEnable the ATM interface.
    Step 9exitExit configuration mode for the ATM 
    interface.
    Command Task
    Step 1router eigrp 100Enter router configuration mode, and enable 
    EIGRP on the router. The autonomous-system 
    number identifies the route to other EIGRP 
    routers and is used to tag the EIGRP 
    information.
    Step 2network numberSpecify the network number for each directly 
    connected network.
    Step 3exitExit router configuration mode. 
    						
    							 
    Chapter 4      Network Scenarios
    Voice Scenario
    4-86
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Configuring the POTS Dial Peers
    Follow the steps below to configure each POTS dial peer, beginning in global 
    configuration mode.
    Configuring VoIP Dial Peers for H.323 Signaling
    Follow the steps below to configure VoIP dial peers for H.323 signaling in global 
    configuration mode.
    Configuration Examples
    This section contains the following configuration examples:
    Cisco 827-4V Router Configuration Example 
    Cisco 3640 Gateway Configuration Example
    Cisco 3640 Gatekeeper Configuration Example Command Task
    Step 1dial-peer voice number POTSEnter configuration mode for the dial peer 
    Step 2destination-pattern stringDefine the destination telephone number 
    associated with the VoIP dial peer.
    Step 3port numberSpecify the port number.
    Command Task
    Step 1dial-peer voice number Vo I PEnter configuration mode for the dial peer. 
    Step 2destination-pattern stringDefine the destination telephone number 
    associated with each VoIP dial peer. 
    Step 3codec g711ulaw Specify a codec if you are not using the 
    default codec of g.729. 
    Step 4ip precedence 5Set the IP precedence.
    Step 5session target ras Specify a destination IP address for each dial 
    peer. 
    						
    							 
    4-87
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Voice Scenario
    Cisco 827-4V Router Configuration Example
    The following is a configuration example for the Cisco 827-4V router portion of 
    the voice network scenario. You do not have to enter the commands marked 
    “default.” These commands appear automatically in the configuration file that is 
    generated when you use the show running-config command.
    !
    class-map voice
    match access-group 101
    !
    route-map data permit 10
    set ip precedence routine
    !
    policy-map mypolicy
    class voice
    priority 176
    class class-default
    fair-queue 16 (default)
    !
    ip subnet-zero
    !
    gateway
    !
    interface Ethernet0
    ip address 20.20.20.20 255.255.255.0
    no ip directed-broadcast (default)
    ip route-cache policy
    ip policy route-map data
    !
    interface ATM0
    ip address 10.10.10.20 255.255.255.0
    no ip directed-broadcast (default)
    no atm ilmi-keepalive (default)
    pvc 1/40
    service-policy output mypolicy
    protocol ip 10.10.10.36 broadcast
    vbr-nrt 640 640 1
    ! 640 is the maximum upstream rate of ADSL
    encapsulation aal5snap
    !
    bundle-enable
    h323-gateway voip interface
    h323-gateway voip id gk-twister ipaddr 172.17.1.1 1719
    h323-gateway voip h323-id gw-820
    h323-gateway voip tech-prefix 1#
    !
    router eigrp 100 
    						
    							 
    Chapter 4      Network Scenarios
    Voice Scenario
    4-88
    Cisco 800 Series Software Configuration Guide
    78-5372-06 network 10.0.0.0
    network 20.0.0.0
    !
    ip classless (default)
    no ip http server
    !
    access-list 101 permit ip any any precedence critical(5)
    !
    line con 0
    exec-timeout 0 0
    transport input none
    stopbits 1
    line vty 0 4
    login
    !
    !
    voice-port 1
    local-alerting
    !
    voice-port 2
    local-alerting
    !
    voice-port 3
    local-alerting
    !
    voice-port 4
    local-alerting
    !
    dial-peer voice 10 voip
    destination-pattern .......
    ip precedence 5
    session target ras
    !
    dial-peer voice 1 pots
    destination-pattern 4085258111
    port 1
    !
    dial-peer voice 2 pots
    destination-pattern 14085258222
    port 2
    !
    dial-peer voice 3 pots
    destination-pattern 14085258333
    port 3
    !
    dial-peer voice 4 pots
    destination-pattern 14085258444
    port 4 
    						
    							 
    4-89
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Voice Scenario
    !
    end
    Cisco 3640 Gateway Configuration Example
    The following is a configuration example for the Cisco 3640 gateway portion of 
    the voice network scenario. You do not have to enter the commands marked 
    “default.” These commands appear automatically in the configuration file that is 
    generated when you use the show running-config command.
    !
    class-map voice
    match access-group 101
    !
    policy-map mypolicy
    class voice
    bandwidth 176
    class class-default
    fair-queue 16
    !
    ip subnet-zero
    !
    cns event-service server
    !
    voice-port 1/0/0
    !
    voice-port 1/0/1
    !
    voice-port 1/1/0
    !
    voice-port 1/1/1
    !
    dial-peer voice 10 voip
    destination-pattern .......
    ip precedence 5
    session target ras
    !
    dial-peer voice 1 pots
    destination-pattern 12125253111
    port 1/0/0
    !
    dial-peer voice 2 pots
    destination-pattern 12125253222
    port 1/0/1
    !
    dial-peer voice 3 pots 
    						
    							 
    Chapter 4      Network Scenarios
    Voice Scenario
    4-90
    Cisco 800 Series Software Configuration Guide
    78-5372-06 destination-pattern 12125253333
    port 1/1/0
    !
    dial-peer voice 4 pots
    destination-pattern 12125253444
    port 1/1/1
    !
    process-max-time 200
    gateway 
    !
    interface Ethernet0/0
    ip address 172.17.1.36 255.255.255.0
    no ip directed-broadcast
    h323-gateway voip interface
    h323-gateway voip id gk-twister ipaddr 172.17.1.1 1719
    h323-gateway voip h323-id gw-3640
    h323-gateway voip tech-prefix 1#
    !
    interface ATM2/0
    ip address 10.10.10.36 255.255.255.0
    no ip directed-broadcast
    no atm ilmi-keepalive
    pvc 8/35 
    service-policy output mypolicy
    protocol ip 10.10.10.20 broadcast
    vbr-rt 1000 600 1
    encapsulation aal5snap
    !
    router eigrp 100
    network 10.0.0.0
    network 172.17.0.0
    !
    no ip classless
    no ip http server
    !
    access-list 101 permit ip any any precedence critical (5)
    !
    line con 0
    exec-timeout 0 0
    transport input none
    line aux 0
    line vty 0 4
    login
    !
    !
    end 
    						
    							 
    4-91
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 4      Network Scenarios
    Voice Scenario
    Cisco 3640 Gatekeeper Configuration Example
    The following is a configuration example for the H.323 gatekeeper portion of the 
    voice network scenario. You do not have to enter the commands marked 
    “default.” These commands appear automatically in the configuration file that is 
    generated when you use the show running-config command.
    !
    class-map voice
    match access-group 101
    !
    !
    policy-map mypolicy
    class voice
    bandwidth 176
    class class-default
    fair-queue 16
    !
    ip subnet-zero
    !
    ip dvmrp route-limit 20000
    !
    process-max-time 200
    !
    interface Ethernet0/0
    ip address 172.28.9.83 255.255.255.0
    no ip directed-broadcast (default)
    !
    interface Ethernet0/1
    ip address 172.17.1.1 255.255.255.0
    no ip directed-broadcast (default)
    !
    router eigrp 100
    network 172.17.0.0
    !
    ip classless (default)
    no ip http server
    !
    !
    gatekeeper
    zone local gk-router router.cisco.com 172.17.1.1
    zone remote gk-sf1 cisco.com 179.15.2.2
    zone remote gk-sf2 lucent.com 180.4.0.1
    zone prefix gk-sf1 1415525....
    zone prefix gk-sf2 1415527....
    !
    line con 0
    exec-timeout 0 0 
    						
    							 
    Chapter 4      Network Scenarios
    Voice Scenario
    4-92
    Cisco 800 Series Software Configuration Guide
    78-5372-06 transport input none
    line aux 0
    line vty 0 4
    password lab
    login
    !
    end 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 800 Series Software Configuration Guide