Home > Cisco > Router > Cisco Router 800 Series Software Configuration Guide

Cisco Router 800 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 800 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    Page
    of 600
    							 
    7-21
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring IP EIGRP
    For complete information on the IP EIGRP commands, refer to the 
    Cisco IOS Release 12.0 documentation set. For more general information on 
    EIGRP concepts, see Chapter 1, “Concepts.”
    Configuration Example
    The following configuration shows EIGRP routing protocol enabled in IP 
    networks 10.0.0.0 and 172.17.0.0. The EIGRP autonomous system number is 
    assigned as 100.
    You do not need to enter the commands marked “default.” These commands 
    appear automatically in the configuration file that is generated when you use the 
    show running-config command.
    !
    router eigrp 100
    network 10.0.0.0
    network 172.17.0.0
    !
    Verifying Your Configuration
    To verify that you have properly configured IP EIGRP, enter the show ip route 
    command and look for EIGRP routes signified by “D.” You should see a 
    verification output like the following example.
    router#sh ip route
    Codes:C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - 
    BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS 
    inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    Gateway of last resort is not set
    2.0.0.0/24 is subnetted, 1 subnets
    C  2.2.2.0 is directly connected, Ethernet0/0
    D    3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0/0 
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring Addressing Parameters
    7-22
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Configuring Addressing Parameters
    This section describes how to configure addressing using Network Address 
    Translation (NAT) and Easy IP Phase 1 and 2.
    Configuring NAT 
    You can configure NAT for either static or dynamic address translations.
    Follow the steps below to configure static or dynamic inside source translation, 
    beginning in global configuration mode.
    Command Task
    Step 1ip nat pool name start-ip end-ip {netmask 
    netmask | prefix-length prefix-length}Create pool of global IP addresses for NAT. 
    Step 2access-list access-list-number permit source 
    [source-wildcard]Define a standard access list permitting 
    addresses that need translation.
    Step 3ip nat inside source list access-list-number 
    pool nameEnable dynamic translation of addresses 
    permitted by access list to one of addresses 
    specified in pool.
    Step 4ip nat inside source static local-ip global-ip 
    number extendableEnable static translation of specified inside 
    local address to globally unique IP address. 
    This command is optional.
    Step 5interface ethernet 0Enter configuration mode for the Ethernet 
    interface.
    Step 6ip nat insideEstablish the Ethernet interface as the inside 
    interface.
    Step 7exitExit configuration mode for the Ethernet 
    interface.
    Step 8interface atm 0Enter configuration mode for the ATM 
    interface.
    Step 9dsl equipment-type {co | cpe} Configure the DSL equipment type, if 
    applicable. 
    						
    							 
    7-23
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring Addressing Parameters
    NoteIf you want to use NAT with a virtual template interface, you must configure a 
    loopback interface.
    For complete information on the NAT commands, refer to the 
    Cisco IOS Release 12.0 documentation set. For general information on NAT 
    concepts, see Chapter 1, “Concepts.”
    Configuration Example
    The following configuration shows NAT configured for the Ethernet and ATM 
    interfaces.
    The Ethernet 0 interface has an IP address of 192.168.1.1 with a subnet mask of 
    255.255.255.0. NAT is configured for inside, which means that the interface is 
    connected to the inside network that is subject to NAT translation.
    The ATM 0 interface has an IP address of 200.200.100.1 and a subnet mask of 
    255.255.255.0. NAT is configured for outside, which means that the interface is 
    connected to an outside network, such as the Internet.
    You do not need to enter the commands marked “default.” These commands 
    appear automatically in the configuration file that is generated when you use the 
    show running-config command.
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    no ip directed-broadcast (default)
    Step 10dsl linerate {number | auto} Specify the G.SHDSL line rate, if applicable. 
    The range of valid numbers is between 72 and 
    2312.
    Step 11dsl operating-mode gshdsl symmetric 
    annex annexSet the G.SHDSL operating mode, if 
    applicable, and select the G.991.2 annex.
    Step 12ip nat outsideEstablish the ATM interface as the outside 
    interface.
    Step 13exitExit configuration mode for the ATM 
    interface. Command Task 
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring Addressing Parameters
    7-24
    Cisco 800 Series Software Configuration Guide
    78-5372-06 ip nat inside
    !
    interface ATM0
    ip address 200.200.100.1 255.255.255.0
    no ip directed-broadcast (default)
    ip nat outside
    no atm ilmi-keepalive (default)
    pvc 8/35 
    encapsulation aal5snap
    !
    ip route 0.0.0.0.0.0.0.0 200.200.100.254
    !
    ip nat pool test 200.200.100.1 200.200.100.1 netmask 255.255.255.0
    ip nat inside source list 101 pool test overload
    ip classless (default)
    !
    Verifying Your Configuration
    To verify that you have properly configured NAT, enter the show ip nat statistics 
    command. You should see a verification output like the example shown below.
    router#sh ip nat statistics 
    Total active translations:45 (10 static, 35 dynamic; 45 extended)
    Outside interfaces:
      ATM0
    Inside interfaces:
      Ethernet0
    Hits:34897598  Misses:44367
    Expired translations:119305
    Dynamic mappings:
    -- Inside Source
    access-list 1 pool homenet refcount 14
    pool homenet:netmask 255.255.255.0
            start 200.200.100.1 end 200.200.100.1
            type generic, total addresses 1, allocated 1 (100%), misses 
    Configuring Easy IP (Phase 1)
    This section explains how to configure Easy IP (Phase 1). Easy IP Phase 1 
    includes NAT overload and PPP/Internet Protocol Control Protocol (IPCP). NAT 
    overload means that you can use one registered IP address for the interface and 
    use it to access the Internet from all devices in the network.  
    						
    							 
    7-25
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring Addressing Parameters
    With PPP/IPCP, Cisco 800 series routers automatically negotiate a globally 
    unique (registered or public) IP address for the interface from the ISP route.
    Follow the steps below to configure Easy IP (Phase 1), beginning in global 
    configuration mode.
    Command Task
    Step 1access-list access-list-number permit source 
    [source-wildcard] Define a standard access list that permits 
    nonregistered IP addresses of hosts.
    Step 2ip nat inside source list access-list-number 
    interface interface overloadSet up translation of addresses identified by 
    the access list defined in Step 1.
    Step 3interface ethernet 0Enter configuration mode for the Ethernet 
    interface.
    Step 4ip nat insideEstablish the Ethernet interface as the inside 
    interface for NAT.
    Step 5no shutdownEnable the Ethernet interface and the 
    configuration changes just made to it.
    Step 6exitExit configuration mode for the Ethernet 
    interface.
    Step 7interface dialer Enter configuration mode for the dialer 
    interface. 
    Step 8ip address negotiatedAssign a negotiated IP address to the dialer 
    interface.
    Step 9ip nat outsideEstablish the dialer interface as the outside 
    interface for NAT.
    Step 10dialer pool numberSpecify which dialer pool number you are 
    using.
    Step 11exitExit the dialer interface.
    Step 12interface ATM 0Enter configuration mode for the ATM 
    interface.
    Step 13dsl equipment-type {co | cpe} Configure the DSL equipment type, if 
    applicable.
    Step 14dsl linerate {number | auto} Specify the G.SHDSL line rate, if applicable. 
    The range of valid numbers is between 72 and 
    2312. 
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring Addressing Parameters
    7-26
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    For complete information on the Easy IP commands, refer to the Cisco IOS 
    Release 12.0 documentation set. For general information on Easy IP (Phase 1) 
    concepts, see Chapter 1, “Concepts.” 
    Configuring Easy IP (Phase 2) 
    This section explains how to configure a Cisco 800 series router as a DHCP 
    server.
    The Easy IP (Phase 2) feature combines DHCP server and relay. With DHCP, 
    LAN devices on an IP network (DHCP clients) can request IP addresses from the 
    DHCP server. The DHCP server allocates IP addresses from a central pool as 
    needed. A DHCP server can be a workstation, PC, or a Cisco router. With the 
    DHCP relay feature configured on the router, the routers can relay IP address 
    requests from the LAN interface and to the DHCP server as shown in Figure 7-1 
    and Ta b l e 7 - 1.
    Step 15dsl operating-mode gshdsl symmetric 
    annex annexSet the G.SHDSL operating mode, if 
    applicable, and select the G.991.2 annex.
    Step 16pvc vpi/vciCreate an ATM PVC for each end node with 
    which the router communicates.
    Step 17encapsulation aal5mux ppp dialer Specify the encapsulation type for the PVC to 
    be AAL5MUX PPP and point back to the 
    dialer interface. 
    Step 18dialer pool-member numberSpecify which dialer pool-member you are 
    using.
    Step 19no shutdownEnable the interface and configuration 
    changes just made to the ATM interface.
    Step 20exitExit configuration mode for the ATM 
    interface. Command Task 
    						
    							 
    7-27
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring DHCP
    Figure 7-1 Easy IP (Phase 2)–DHCP Server and Relay
    Configuring DHCP
    The following sections describe how to configure the router as a DHCP client, 
    server, or relay.
    Configuring DHCP Client Support
    Follow these steps to configure the router for DHCP client support:
    Step 1Configure the BVI interface by entering the ip address dhcp client-id Ethernet 
    0 command. 
    Cisco 827 Cisco 3600
    AT M
    74583
    1
    3
    24
    5
    Table 7-1 Key for Easy IP (Phase 2)–DHCP Server and Relay
    Callout 
    Number Description
    1 DHCP client
    2 Remote office with Cisco 827 router
    3 DHCP relay
    4 Corporate office with Cisco 3600 router
    5 DHCP server 
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring DHCP
    7-28
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Specifying the value client-id ethernet0 means that the MAC address of the 
    Ethernet interface is used as the client ID when the DHCP request is sent. 
    Otherwise, the MAC address of the BVI interface is used as the client ID.
    Step 2Configure NAT:
    a.Configure the BVI interface by entering the ip nat outside command.
    b.Configure the Ethernet interface by entering the ip nat inside command.
    c.Create an access list under NAT by entering the access-list 1 permit ip 
    address command to match all Ethernet IP addresses.
    d.Configure the source list under NAT by entering the 
    ip nat inside source list 1 interface BVI 1 overload command.
    Step 3Configure the Cisco router to act as a DHCP server. This step is optional.
    a.At the config-if router prompt, enter the ip dhcp pool server name 
    command.
    b.Enter the import all command to have the Cisco router retrieve the Microsoft 
    Windows nameserver (WINS) and domain name system (DNS) server 
    addresses for name resolution.
    Configuration Example
    The following example shows a configuration of the DHCP client.
    Current configuration:
    !
    version 12.0
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname c827
    !
    !
    ip subnet-zero
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool SERVER
    network 10.10.10.0 255.255.255.0 
    						
    							 
    7-29
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 7      Router Feature Configuration
    Configuring DHCP
    default-router 10.10.10.1 
    import all
    ! 
    bridge irb
    interface Ethernet0
    ip address 10.10.10.1 255.255.255.0
    no ip directed-broadcast
    ip nat inside
    !
    interface ATM0
    no ip address
    no ip directed-broadcast
    no atm ilmi-keepalive
    bundle-enable
    hold-queue 208 in
    !
    interface ATM0.1 point-to-point
    no ip directed-broadcast
    pvc 1/100 
    encapsulation aal5snap
    !
    bridge-group 1
    !
    interface ATM0.2 point-to-point
    ip address 5.0.0.2 255.0.0.0
    no ip directed-broadcast
    pvc 1/101 
    protocol ip 5.0.0.1 broadcast
    protocol ip 5.0.0.5 broadcast
    encapsulation aal5snap
    !
    !
    interface BVI1
    ip address dhcp client-id Ethernet0
    no ip directed-broadcast
    ip nat outside
    !
    ip nat inside source list 1 interface BVI1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 BVI1
    no ip http server
    !
    access-list 1 permit 10.10.10.0 0.0.0.255
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    voice-port 1
    timing hookflash-in 0 
    						
    							 
    Chapter 7      Router Feature Configuration
    Configuring DHCP
    7-30
    Cisco 800 Series Software Configuration Guide
    78-5372-06 !
    voice-port 2
    timing hookflash-in 0
    !
    voice-port 3
    timing hookflash-in 0
    !
    voice-port 4
    timing hookflash-in 0
    !
    !
    line con 0
    exec-timeout 0 0
    transport input none
    stopbits 1
    line vty 0 4
    password lab
    login    
    !
    scheduler max-task-time 5000
    end
    Configuring DHCP Server
    Follow the steps below to configure the router as a DHCP server, beginning in 
    global configuration mode.
    Command Task
    Step 1ip dhcp pool nameEnter DHCP configuration mode, and create a 
    pool of IP addresses that can be assigned to 
    DHCP clients.
    Step 2network ip-address subnet-maskSpecify a range of IP addresses that can be 
    assigned to the DHCP clients.
    Step 3domain-name domain nameConfigure the domain name.
    Step 4dns-server ip-addressDesignate the router as the default router, and 
    specify an IP address.
    Step 5netbios-name-server ip-addressConfigure the netbios name server.
    Step 6default-router ip-addressConfigure the DNS server. 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 800 Series Software Configuration Guide