Home > Cisco > Router > Cisco Router 800 Series Software Configuration Guide

Cisco Router 800 Series Software Configuration Guide

    Download as PDF Print this page Share this page

    Have a look at the manual Cisco Router 800 Series Software Configuration Guide online for free. It’s possible to download the document as PDF or print. UserManuals.tech offer 53 Cisco manuals and user’s guides for free. Share the user manual or guide on Facebook, Twitter or Google+.

    Page
    of 600
    							 
    8-15
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 8      Advanced Router Configuration
    Configuring DHCP Server Import
    Cisco SOHO 77, SOHO 77H, SOHO 78, SOHO 91, SOHO 96 and SOHO 97
    Cisco 828
    Follow the steps below to configure the Cisco router for DHCP server import:
    Step 1Configure the asynchronous transfer mode (ATM) interface and the asymmetric 
    digital subscriber line (ADSL) operating mode.
    Step 2Create an ATM PVC for data traffic, enter virtual circuit configuration mode, 
    and specify the virtual path identifier/virtual channel identifier (VPI/VCI) 
    values, the encapsulation type, and the dial-pool member.
    Step 3Create a dialer interface.
    a.Enter configuration mode for the dialer interface.
    b.Specify the MTU size as 1492.
    c.Assign ip address negotiated to the dialer interface.
    d.Configure the dialer group number. 
    e.Configure PPP encapsulation and (if needed) Challenge Handshake 
    Authentication Protocol (CHAP).
    f.Configure IP negotiation of DNS and WINS requests.
    Step 4Define an IP DHCP pool name.
    a.Configure the network and domain name (if needed) for the DHCP pool.
    b.Enter the import all command.
    Step 5Configure a dialer list and a static route for the dialer interface.
    Configuration Examples
    The following example shows a configuration of the DHCP server import on the 
    Cisco 800 series and Cisco SOHO series routers. 
    router-820#show run
    Building configuration...
    Current configuration :1510 bytes
    version 12.1
    no service single-slot-reload-enable
    no service pad 
    						
    							 
    Chapter 8      Advanced Router Configuration
    Configuring DHCP Server Import
    8-16
    Cisco 800 Series Software Configuration Guide
    78-5372-06 service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname router-820
    logging rate-limit console 10 except errors
    !
    username 3620-4 password 0 lab
    mmi polling-interval 60
    mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    no ip finger
    no ip domain-lookup
    !
    ip dhcp excluded-address 192.150.2.100
    ip dhcp pool 2
    import all
    network 192.150.2.0 255.255.255.0
    domain-name devtest.com
    default-router 192.150.2.100 
    lease 0 0 3
    !
    no ip dhcp-client network-discovery
    vpdn enable
    no vpdn logging
    vpdn-group 1
    request-dialin
    protocol pppoe
    call rsvp-sync
    !
    interface Ethernet0
    ip address 192.150.2.100 255.255.255.0
    ip nat inside
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 0/16 ilmi
    !
    pvc 1/40 
    protocol pppoe
    pppoe-client dial-pool-number 1
    !
    bundle-enable
    dsl operating-mode auto 
    						
    							 
    8-17
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 8      Advanced Router Configuration
    Configuring DHCP Server Import
    !
    interface Dialer0
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap
    ppp ipcp dns request
    ppp ipcp wins request
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    no ip http server
    !
    ip nat inside source list 101 interface Dialer0 overload
    access-list 101 permit ip any any
    dialer-list 1 protocol ip list 101
    snmp-server manager
    !
    voice-port 1
    voice-port 2
    voice-port 3
    voice-port 4
    !
    line con 0
    transport input none
    stopbits 1
    line vty 0 4
    scheduler max-task-time 5000
    end
    The following example shows a DHCP proxy client configuration on the 
    Cisco 800 series and Cisco SOHO series routers:
    3620-4#show run
    version 12.1
    no service single-slot-reload-enable
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname 3620-4
    logging rate-limit console 10 except errors
    !
    username 820-uut1 password 0 lab
    username 820-uut4 password 0 lab 
    						
    							 
    Chapter 8      Advanced Router Configuration
    Configuring DHCP Server Import
    8-18
    Cisco 800 Series Software Configuration Guide
    78-5372-06 memory-size iomem 10
    ip subnet-zero
    !
    no ip finger
    !
    ip address-pool dhcp-proxy-client
    ip dhcp-server 192.150.1.101
    vpdn enable
    no vpdn logging
    !
    vpdn-group 1
    accept-dialin
    protocol pppoe
    virtual-template 1
    !
    call rsvp-sync
    cns event-service server
    !
    interface Ethernet0/0
    ip address 192.150.1.100 255.255.255.0
    half-duplex
    !
    interface Ethernet0/1
    no ip address
    shutdown
    half-duplex
    !
    interface ATM1/0
    no ip address
    no atm scrambling cell-payload
    no atm ilmi-keepalive
    pvc 1/40 
    encapsulation aal5snap
    protocol pppoe
    !
    interface Virtual-Template1
    ip address 2.2.2.1 255.255.255.0
    ip mtu 1492
    peer default ip address dhcp
    ppp authentication chap
    !
    ip kerberos source-interface any
    ip classless
    ip route 0.0.0.0 0.0.0.0 Ethernet0/0
    no ip http server
    !
    dialer-list 1 protocol ip permit
    dial-peer cor custom 
    						
    							 
    8-19
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 8      Advanced Router Configuration
    Configuring DHCP Server Import
    !
    line con 0
    exec-timeout 0 0
    transport input none
    line aux 0
    line vty 0 4
    login
    end
    The following example shows a configuration on the remote DHCP server on the 
    Cisco 800 series and Cisco SOHO series routers.
    2500ref-4#show run
    version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname 2500ref-4
    !
    no logging console
    !
    ip subnet-zero
    no ip domain-lookup
    ip host PAGENT-SECURITY-V3 45.41.44.82 13.15.0.0
    ip dhcp excluded-address 2.2.2.1
    !
    ip dhcp pool 1
    network 2.2.2.0 255.255.255.0
    dns-server 53.26.25.23 
    netbios-name-server 66.22.66.22 
    domain-name ribu.com
    lease 0 0 5
    !
    cns event-service server
    !
    interface Ethernet0
    ip address 192.150.1.101 255.255.255.0
    interface Ethernet1
    ip address 192.168.254.165 255.255.255.0
    interface Serial0
    no ip address
    shutdown
    no fair-queue
    interface Serial1
    no ip address 
    						
    							 
    Chapter 8      Advanced Router Configuration
    Configuring IP Control Protocol Subnet Mask Delivery
    8-20
    Cisco 800 Series Software Configuration Guide
    78-5372-06 shutdown
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.1.1.1
    ip route 0.0.0.0 0.0.0.0 Ethernet0
    no ip http server
    !
    dialer-list 1 protocol ip permit
    line con 0
    exec-timeout 0 0
    transport input none
    line aux 0
    transport input all
    line vty 0 4
    login
    no scheduler max-task-time
    end
    Configuring IP Control Protocol Subnet Mask 
    Delivery
    The IP control protocol subnet mask delivery feature is supported on the 
    following Cisco routers:
    Cisco 806
    Cisco 826 and 836
    Cisco 827, 827H, 827-4V, 831, and 837 
    Cisco SOHO 77, SOHO 77H, SOHO 78, SOHO 91, SOHO 96, and SOHO 97
    Cisco 828 
    The IP Control Protocol (IPCP) feature assigns IP address pools to customer 
    premises equipment (CPE) devices. These devices then assign IP addresses to the 
    CPE and to a DHCP pool. 
    IPCP provides the following functions:
    The Cisco IOS CPE device requests and uses the subnet.
    The authentication, authorization, and accounting (AAA) Remote 
    Authentication Dial-In User Service (RADIUS) provides the subnet and 
    inserts the framed route into the proper virtual route forwarding (VRF) table. 
    						
    							 
    8-21
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 8      Advanced Router Configuration
    Configuring IP Control Protocol Subnet Mask Delivery
    The provider edge or the edge router helps in providing the subnet through 
    IPCP.
    DHCP is no longer supported on the client side because the CPE can now receive 
    both the IP address and the subnet mask during the PPP setup negotiation. If the 
    CPE uses the DHCP servers to allocate addresses for its own network, subnets can 
    be assigned through the node route processor (NRP) on the network access server 
    (NAS) and distributed to the remote CPE DHCP servers.
    Follow the steps below to configure the CPE for IPCP:
    Step 1Configure the ATM interface, and enter the ADSL operating mode.
    Step 2Configure the ATM subinterface.
    a.Create an ATM PVC for data traffic, enter virtual circuit configuration mode, 
    and specify the VPI and VCI values.
    b.Set the encapsulation of the PVC as aal5mux ppp to support data traffic.
    Step 3Create a dialer interface.
    a.Enter configuration mode for the dialer interface.
    b.Specify the PPP encapsulation type for the PVC.
    c.Enter the ip unnumbered Ethernet 0 command to assign the Ethernet 
    interface to the dialer interface.
    d.Configure the dialer group number. 
    e.Configure CHAP.
    f.Enter the ppp ipcp mask request command.
    g.Assign a dialer list to this dialer interface.
    Step 4Define an IP DHCP pool name.
    a.Enter the import all command.
    b.Enter the origin ipcp command.
    Step 5Configure the Ethernet interface, and assign an IP address pool. Enter the pool 
    name that you defined in Step 4. 
    Step 6Configure a dialer list and a static route for the dialer interface. 
    						
    							 
    Chapter 8      Advanced Router Configuration
    Configuring IP Control Protocol Subnet Mask Delivery
    8-22
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Configuration Examples
    The following example shows a IPCP configuration on the Cisco 827-4V router:
    router-8274v-1# show run
    Building configuration...
    Current configuration :1247 bytes
    version 12.2
    no service single-slot-reload-enable
    no service pad
    service timestamps debug datetime msec
    service timestamps log uptime
    no service password-encryption
    !
    hostname router-8274v-1
    !
    no logging buffered
    logging rate-limit console 10 except errors
    !
    username 6400-nrp2 password 0 lab
    ip subnet-zero
    ip dhcp smart-relay
    !
    ip dhcp pool IPPOOLTEST
    import all
    origin ipcp
    lease 0 0 1
    !
    no ip dhcp-client network-discovery
    !
    interface Ethernet0
    ip address pool IPPOOLTEST
    no shutdown
    hold-queue 32 in
    !
    interface ATM0
    no ip address
    atm ilmi-keepalive
    bundle-enable
    dsl operating-mode auto
    hold-queue 224 in
    !
    interface ATM0.1 point-to-point
    pvc 1/40 
    no ilmi manage
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    ! 
    						
    							 
    8-23
    Cisco 800 Series Software Configuration Guide
    78-5372-06
    Chapter 8      Advanced Router Configuration
    Configuring IP Control Protocol Subnet Mask Delivery
    interface Dialer0
    ip unnumbered Ethernet0
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname router-8274v-1
    ppp chap password 7 12150415
    ppp ipcp accept-address
    ppp ipcp dns request
    ppp ipcp wins request
    ppp ipcp mask request
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    no ip http server
    !
    dialer-list 1 protocol ip permit
    !
    line con 0
    exec-timeout 0 0
    stopbits 1
    line vty 0 4
    login
    !
    scheduler max-task-time 5000
    end
    The following example shows an IPCP configuration on the remote server for a 
    Cisco 827-4V router:
    6400-nrp2#show run
    Building configuration...
    Current configuration :1654 bytes
    !
    version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname 6400-nrp2
    !
    aaa new-model
    aaa authentication ppp default group radius
    aaa authorization network default group radius 
    aaa nas port extended 
    						
    							 
    Chapter 8      Advanced Router Configuration
    Configuring IP Control Protocol Subnet Mask Delivery
    8-24
    Cisco 800 Series Software Configuration Guide
    78-5372-06 enable password lab
    !
    username router-8274v-1 password 0 lab
    username TB2-8274v-2 password 0 lab
    !
    redundancy
    main-cpu
    auto-sync standard
    no secondary console enable
    ip subnet-zero
    no ip finger
    !
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    hold-queue 500 in
    !
    interface ATM0/0/0.4 point-to-point
    pvc 6/40 
    encapsulation aal5mux ppp Virtual-Template5
    !
    !interface ATM0/0/0.5 point-to-point
    pvc 5/46 
    protocol ip 7.0.0.60 broadcast
    encapsulation aal5mux ppp Virtual-Template6
    !
    interface Ethernet0/0/1
    no ip address
    shutdown
    !
    interface Ethernet0/0/0
    description admin IP address 192.168.254.201 255.255.255.0
    ip address 192.168.254.240 255.255.255.0
    !
    interface FastEthernet0/0/0
    ip address 192.168.100.101 255.255.255.0
    half-duplex
    !
    interface Virtual-Template5
    ip unnumbered FastEthernet0/0/0
    no keepalive
    no peer default ip address
    ppp authentication chap
    !
    interface Virtual-Template6
    ip unnumbered FastEthernet0/0/0
    no peer default ip address
    ppp authentication chap 
    						
    All Cisco manuals Comments (0)

    Related Manuals for Cisco Router 800 Series Software Configuration Guide